aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-03-20 21:45:59 +0100
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-03-20 21:45:59 +0100
commit0c2f30af96090c8bb4985d619fced60d0d74d3fe (patch)
tree74d73c61dac36e2ae0e76bd85fc6315f24fc1e09 /app-misc/wcal/wcal-0.1-r1.ebuild
parentsys-libs/gcompat: new package, add 1.1.0 (diff)
downloadguru-0c2f30af96090c8bb4985d619fced60d0d74d3fe.tar.gz
guru-0c2f30af96090c8bb4985d619fced60d0d74d3fe.tar.bz2
guru-0c2f30af96090c8bb4985d619fced60d0d74d3fe.zip
app-misc/wcal: respect CFLAGS
Closes: https://bugs.gentoo.org/927327 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'app-misc/wcal/wcal-0.1-r1.ebuild')
-rw-r--r--app-misc/wcal/wcal-0.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/wcal/wcal-0.1-r1.ebuild b/app-misc/wcal/wcal-0.1-r1.ebuild
new file mode 100644
index 000000000..21c1ab633
--- /dev/null
+++ b/app-misc/wcal/wcal-0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="ISO weekly calendar"
+HOMEPAGE="https://github.com/leahneukirchen/wcal"
+SRC_URI="https://github.com/leahneukirchen/wcal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+
+# check target in Makefile but no test cases
+RESTRICT="test"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}