aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-06-21 22:59:33 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-06-21 23:00:07 +0500
commit370cd056fe7fdbfc12e95d65022d3f9f472decde (patch)
treef1c8b444bc8bf1d7c64e99bb88ad77f7849d8692 /app-portage
parentapp-misc/onefetch: drop 2.17.1 (diff)
downloadguru-370cd056fe7fdbfc12e95d65022d3f9f472decde.tar.gz
guru-370cd056fe7fdbfc12e95d65022d3f9f472decde.tar.bz2
guru-370cd056fe7fdbfc12e95d65022d3f9f472decde.zip
app-portage/gentle: add 0.2
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentle/Manifest1
-rw-r--r--app-portage/gentle/gentle-0.1.ebuild2
-rw-r--r--app-portage/gentle/gentle-0.2.ebuild32
3 files changed, 34 insertions, 1 deletions
diff --git a/app-portage/gentle/Manifest b/app-portage/gentle/Manifest
index 2a242c943..40106810c 100644
--- a/app-portage/gentle/Manifest
+++ b/app-portage/gentle/Manifest
@@ -1 +1,2 @@
DIST gentle-0.1.tar.xz 17376 BLAKE2B 88d3fc7af3e153183d8da3d86e51b72d7c11f52b2d8db879d7854900c8f1654bb1a907403edfe741a6a4165266b833522408a52cd79c48b145eee2e8978ed34e SHA512 022406f2bffa559149fe53549a3e9243325d695ca3632959221402f1f770208ecb3eb49033d23daa83e971ddd505a335c5213bc9067f41443cb9e574f3bfd15a
+DIST gentle-0.2.tar.xz 31524 BLAKE2B 18dc26ffe778964360b3a9ea5057f2bfa54bcfd6bc411a49bff125b7ac69b9e9626eeb1d4a68241a8c5023f6cd6131c644cf5af83cece8929367923c6d675b7c SHA512 87b5e06b98ae1206eb36a04f78493f3819334935477e084484d175e774dfa8195ebe9204362b635eec682f31987a7f4f5e6cb8df5711d3b9348d0bb97ab24aa6
diff --git a/app-portage/gentle/gentle-0.1.ebuild b/app-portage/gentle/gentle-0.1.ebuild
index d23e040da..899f670aa 100644
--- a/app-portage/gentle/gentle-0.1.ebuild
+++ b/app-portage/gentle/gentle-0.1.ebuild
@@ -20,7 +20,7 @@ BDEPEND="
app-text/xmldiff[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
$(python_gen_cond_dep \
- 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10 )
+ 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
)
"
diff --git a/app-portage/gentle/gentle-0.2.ebuild b/app-portage/gentle/gentle-0.2.ebuild
new file mode 100644
index 000000000..899f670aa
--- /dev/null
+++ b/app-portage/gentle/gentle-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Gentoo Lazy Entry - a metadata.xml generator"
+HOMEPAGE="https://git.sysrq.in/gentle"
+SRC_URI="https://git.sysrq.in/${PN}/snapshot/${P}.tar.xz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ app-text/xmldiff[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "yaml support" dev-python/pyyaml
+ optfeature "toml support" dev-python/tomli
+}