aboutsummaryrefslogtreecommitdiff
path: root/dev-R
diff options
context:
space:
mode:
authorRobert Greener <me@r0bert.dev>2022-07-03 14:47:48 +0100
committerRobert Greener <me@r0bert.dev>2022-07-03 14:47:48 +0100
commitd5116714ad1b1264ae9467d6cbfac4497b490e66 (patch)
tree4e2298e0b42d497771cb67c131902139f0662dce /dev-R
parentdev-R/tinytest: new package, add 1.3.1 (diff)
downloadguru-d5116714ad1b1264ae9467d6cbfac4497b490e66.tar.gz
guru-d5116714ad1b1264ae9467d6cbfac4497b490e66.tar.bz2
guru-d5116714ad1b1264ae9467d6cbfac4497b490e66.zip
dev-R/RcppEigen: new package, add 0.3.3.9.2
Signed-off-by: Robert Greener <me@r0bert.dev>
Diffstat (limited to 'dev-R')
-rw-r--r--dev-R/RcppEigen/Manifest1
-rw-r--r--dev-R/RcppEigen/RcppEigen-0.3.3.9.2.ebuild32
-rw-r--r--dev-R/RcppEigen/metadata.xml17
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-R/RcppEigen/Manifest b/dev-R/RcppEigen/Manifest
new file mode 100644
index 000000000..a44354498
--- /dev/null
+++ b/dev-R/RcppEigen/Manifest
@@ -0,0 +1 @@
+DIST RcppEigen_0.3.3.9.2.tar.gz 1476004 BLAKE2B c111b13bd34acf75e061302628e6821a506736717ae938a0105d45a5ee0f638439ebdb5e83e9319157deee81b96a928438c4d3d9d1be69ef64dcdab56425f44c SHA512 167ec253d2729fb03c822465d40f23a756a32c23280baf340255d6d700846fe220266273201f8144fb7ac040261e915f3e5058b5f4241d5f1070f2ae2c37c121
diff --git a/dev-R/RcppEigen/RcppEigen-0.3.3.9.2.ebuild b/dev-R/RcppEigen/RcppEigen-0.3.3.9.2.ebuild
new file mode 100644
index 000000000..78f8d5631
--- /dev/null
+++ b/dev-R/RcppEigen/RcppEigen-0.3.3.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit R-packages edo
+
+DESCRIPTION="'Rcpp' Integration for the 'Eigen' Templated Linear Algebra Library"
+KEYWORDS="~amd64"
+LICENSE='GPL-2+'
+RESTRICT="!test? ( test )"
+IUSE="test"
+
+DEPEND="
+ || ( dev-R/Matrix dev-lang/R[-minimal] )
+ dev-R/Rcpp
+ test? (
+ dev-R/tinytest
+ )
+"
+
+SUGGESTED_PACKAGES="
+ dev-R/inline
+ dev-R/tinytest
+ dev-R/pkgKitten
+ dev-R/microbenchmark
+"
+
+src_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ R_LIBS="${T}/R" edo Rscript --vanilla tinytest.R
+}
diff --git a/dev-R/RcppEigen/metadata.xml b/dev-R/RcppEigen/metadata.xml
new file mode 100644
index 000000000..c69914493
--- /dev/null
+++ b/dev-R/RcppEigen/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>me@r0bert.dev</email>
+ <name>Robert Greener</name>
+ </maintainer>
+ <longdescription lang="en">R and 'Eigen' integration using 'Rcpp'. 'Eigen' is a C++ template library for linear algebra: matrices, vectors, numerical solvers and related algorithms. It supports dense and sparse matrices on integer, floating point and complex numbers, decompositions of such matrices, and solutions of linear systems. Its performance on many algorithms is comparable with some of the best implementations based on 'Lapack' and level-3 'BLAS'. The 'RcppEigen' package includes the header files from the 'Eigen' C++ template library (currently version 3.3.4). Thus users do not need to install 'Eigen' itself in order to use 'RcppEigen'. Since version 3.1.1, 'Eigen' is licensed under the Mozilla Public License (version 2); earlier version were licensed under the GNU LGPL version 3 or later. 'RcppEigen' (the 'Rcpp' bindings/bridge to 'Eigen') is licensed under the GNU GPL version 2 or later, as is the rest of 'Rcpp'.</longdescription>
+ <upstream>
+ <maintainer>
+ <name>Dirk Eddelbuettel</name>
+ <email>edd@debian.org</email>
+ </maintainer>
+ <bugs-to>https://github.com/RcppCore/RcppEigen/issues</bugs-to>
+ <remote-id type="github">RcppCore/RcppEigen</remote-id>
+ </upstream>
+</pkgmetadata>