aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-01-21 23:28:09 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2024-01-21 23:28:09 +0300
commita9bbc909ac4f5c8e25e9cd67207e735d953d0110 (patch)
treea4bd7e65434b0fe47c20924a1ce6b61937aaef13 /dev-build
parentdev-libs/StringiFor: update {dev-util → dev-build}/FoBiS (diff)
downloadguru-a9bbc909ac4f5c8e25e9cd67207e735d953d0110.tar.gz
guru-a9bbc909ac4f5c8e25e9cd67207e735d953d0110.tar.bz2
guru-a9bbc909ac4f5c8e25e9cd67207e735d953d0110.zip
Move {dev-util → dev-build}/fypp
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/fypp/Manifest2
-rw-r--r--dev-build/fypp/files/filevarroot.fypp5
-rw-r--r--dev-build/fypp/fypp-3.1.ebuild24
-rw-r--r--dev-build/fypp/fypp-3.2.ebuild29
-rw-r--r--dev-build/fypp/metadata.xml17
5 files changed, 77 insertions, 0 deletions
diff --git a/dev-build/fypp/Manifest b/dev-build/fypp/Manifest
new file mode 100644
index 000000000..f5d7f919d
--- /dev/null
+++ b/dev-build/fypp/Manifest
@@ -0,0 +1,2 @@
+DIST fypp-3.1.tar.gz 68237 BLAKE2B 504fe6c655da647b9d30554afe1c0c036f636991562001763180425a572e03b52ceaf0287e68f82ea534914cd61d176fb4bad7fba5562bb1597500d80ae8c919 SHA512 91638d957f6a4306f23406b6a235e8ee8258cf9065e9b8dc3e137bbe651a2e1397f557292f2b4d3628a57ef6ced67df150c25c0bf304944f7c1b2b5b85087bd5
+DIST fypp-3.2.tar.gz 69307 BLAKE2B f84738dafdacc48e41fe67a10d1dafabee8b531b3171f1e0fda6e180ab579cffbd2276f3004a54a428f5adf4409347b639c2339297cfe4d1e8a468cc306b6039 SHA512 79cdaaf540447d72a665360ae8dbdea52d71b2d1a3a8733e35a258d0050d0e77729414e1c59d9905349d3ef61f1a943348efce3fffddd80affd808a0b2660ea3
diff --git a/dev-build/fypp/files/filevarroot.fypp b/dev-build/fypp/files/filevarroot.fypp
new file mode 100644
index 000000000..9eb9a2a72
--- /dev/null
+++ b/dev-build/fypp/files/filevarroot.fypp
@@ -0,0 +1,5 @@
+FILE: ${_FILE_}$:${_LINE_}$
+THIS_FILE: ${_THIS_FILE_}$:${_THIS_LINE_}$
+---
+#:include "filevarroot.inc"
+$:macro()
diff --git a/dev-build/fypp/fypp-3.1.ebuild b/dev-build/fypp/fypp-3.1.ebuild
new file mode 100644
index 000000000..e89a1a89a
--- /dev/null
+++ b/dev-build/fypp/fypp-3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fypp - Python powered Fortran preprocessor"
+HOMEPAGE="https://github.com/aradi/fypp"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ # pass python version as arg
+ test/runtests.sh ${EPYTHON} || die
+}
diff --git a/dev-build/fypp/fypp-3.2.ebuild b/dev-build/fypp/fypp-3.2.ebuild
new file mode 100644
index 000000000..5f121b3fc
--- /dev/null
+++ b/dev-build/fypp/fypp-3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fypp - Python powered Fortran preprocessor"
+HOMEPAGE="https://github.com/aradi/fypp"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}/filevarroot.fypp" "${S}/test/input/" || die
+}
+
+python_test() {
+ # pass python version as arg
+ test/runtests.sh ${EPYTHON} || die
+}
diff --git a/dev-build/fypp/metadata.xml b/dev-build/fypp/metadata.xml
new file mode 100644
index 000000000..1a87c738a
--- /dev/null
+++ b/dev-build/fypp/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fypp is a Python powered preprocessor.
+ It can be used for any programming languages but its primary aim is to offer a Fortran preprocessor,
+ which helps to extend Fortran with condititional compiling and template metaprogramming capabilities.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">fypp</remote-id>
+ <remote-id type="github">aradi/fypp</remote-id>
+</upstream>
+</pkgmetadata>