aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-06-18 14:42:04 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-06-18 14:42:04 +0200
commit752a239d4daa73eb307f221dd2b95192f968cbce (patch)
tree541ad5b9da5efe247b5435fc3adfe9a9ab5b5e92 /dev-embedded
parentdev-embedded/idf-component-manager: add 1.5.3 (diff)
downloadguru-752a239d4daa73eb307f221dd2b95192f968cbce.tar.gz
guru-752a239d4daa73eb307f221dd2b95192f968cbce.tar.bz2
guru-752a239d4daa73eb307f221dd2b95192f968cbce.zip
dev-embedded/idf-component-manager: drop 1.4.1, 1.5.2
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/idf-component-manager/Manifest2
-rw-r--r--dev-embedded/idf-component-manager/idf-component-manager-1.4.1.ebuild48
-rw-r--r--dev-embedded/idf-component-manager/idf-component-manager-1.5.2.ebuild49
3 files changed, 0 insertions, 99 deletions
diff --git a/dev-embedded/idf-component-manager/Manifest b/dev-embedded/idf-component-manager/Manifest
index 8d75e9287..60fbf9985 100644
--- a/dev-embedded/idf-component-manager/Manifest
+++ b/dev-embedded/idf-component-manager/Manifest
@@ -1,3 +1 @@
-DIST idf-component-manager-1.4.1.gh.tar.gz 222994 BLAKE2B 659272939460a95f67156aaa978ad78e00f9dd138a63310559e8229927e6328d0c2939a9df15dd5c54af2f7f2527e10ac90211974c90c9cc4b127e000ac5b653 SHA512 fe1205728b6dd91dbc158a2112b0b216b3631fae8982b4f51e2905bdcf45cf5ad697201b56cac9413b72c663d61ce55c831a758453a4c0c904a29f5b1d64cfbf
-DIST idf-component-manager-1.5.2.gh.tar.gz 318633 BLAKE2B 13064fdbebf672dee91b764c83ee07bebf64504676ec25ec9c40d181425c177e4080e6da2b3435115afeeff2608bc2a2a5545dc64d0e5d01e1e817c88fcdc0a9 SHA512 113d750956ce5935483f54884ea7290d6ebcc463ffaab5ae602a8ea341326ea1dffde5c929de155514fbd8692964801c787bc962d0c78dc87a27d841e004bd99
DIST idf-component-manager-1.5.3.gh.tar.gz 321425 BLAKE2B 1c5b1bd1dc50b214b5b9a8d4ae40681fd33118f4d83469d793de152627d2cd2e2497f3a7e771b27a5aac68886d242e2f3d44c69d94f38ce3385d8bec0700190a SHA512 6a8d5c493f5f361c3b02a145685b58862e8e96261cbe3c5436354446f95f5ca5782a9dd7fa5397bc58438166c07aea6bb958348d596f6a604d5044edba0584c0
diff --git a/dev-embedded/idf-component-manager/idf-component-manager-1.4.1.ebuild b/dev-embedded/idf-component-manager/idf-component-manager-1.4.1.ebuild
deleted file mode 100644
index 216816205..000000000
--- a/dev-embedded/idf-component-manager/idf-component-manager-1.4.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{11,12} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Tool for installing ESP-IDF components"
-HOMEPAGE="https://github.com/espressif/idf-component-manager"
-SRC_URI="https://github.com/espressif/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="
- test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/vcrpy[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-RDEPEND="
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/requests-file[${PYTHON_USEDEP}]
- dev-python/schema[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- <dev-python/urllib3-2.0.0[${PYTHON_USEDEP}]
-"
-
-# Requires additional files not available in the tarball
-EPYTEST_DESELECT=(
- tests/test_component_manager.py::test_pack_component_with_examples_errors
-)
-
-distutils_enable_tests pytest
diff --git a/dev-embedded/idf-component-manager/idf-component-manager-1.5.2.ebuild b/dev-embedded/idf-component-manager/idf-component-manager-1.5.2.ebuild
deleted file mode 100644
index 436be4935..000000000
--- a/dev-embedded/idf-component-manager/idf-component-manager-1.5.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{11,12} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Tool for installing ESP-IDF components"
-HOMEPAGE="https://github.com/espressif/idf-component-manager"
-SRC_URI="https://github.com/espressif/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="
- test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/vcrpy[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-RDEPEND="
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/requests-file[${PYTHON_USEDEP}]
- dev-python/schema[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- <dev-python/urllib3-2.0.0[${PYTHON_USEDEP}]
-"
-
-# Requires additional files not available in the tarball
-EPYTEST_DESELECT=(
- tests/test_component_manager.py::test_pack_component_with_examples_errors
- tests/test_component_manager.py::test_pack_component_with_dest_dir
-)
-
-distutils_enable_tests pytest