aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-06-19 09:14:49 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-06-19 09:14:56 +0200
commitb8d29619de43a844d6b94f313cbf1c94fd01c6f8 (patch)
tree5cff65402223ce5c695cd3da87b08c534f41c695 /dev-embedded
parentdev-embedded/esp-idf: drop failing rm in case of USE=riscv32 (diff)
downloadguru-b8d29619de43a844d6b94f313cbf1c94fd01c6f8.tar.gz
guru-b8d29619de43a844d6b94f313cbf1c94fd01c6f8.tar.bz2
guru-b8d29619de43a844d6b94f313cbf1c94fd01c6f8.zip
dev-embedded/esp-idf: use estack.eclass and newbin with heredoc
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esp-idf/esp-idf-5.2.2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-embedded/esp-idf/esp-idf-5.2.2.ebuild b/dev-embedded/esp-idf/esp-idf-5.2.2.ebuild
index af3eb9ab0..075aec06e 100644
--- a/dev-embedded/esp-idf/esp-idf-5.2.2.ebuild
+++ b/dev-embedded/esp-idf/esp-idf-5.2.2.ebuild
@@ -10,7 +10,7 @@ GDB_VER="14.2_20240403"
CROSSTOOL_URL="https://github.com/espressif/crosstool-NG/releases/download/esp-${VER}"
-inherit python-r1
+inherit estack python-r1
DESCRIPTION="Espressif IoT Development Framework"
HOMEPAGE="https://www.espressif.com/"
@@ -67,7 +67,7 @@ PATCHES=(
)
install_tool() {
- shopt -s globstar
+ eshopts_push -s globstar
into /opt/${1}
@@ -119,12 +119,17 @@ install_tool() {
done
)
- shopt -u globstar
+ eshopts_pop
}
src_install() {
- echo -e "#!/bin/sh\npython /usr/share/${PN}/tools/idf.py \"\$@\"" > idf
- dobin idf
+ newbin - idf <<-EOF
+ #!/bin/sh
+
+ # Silence a warning by idf.py
+ export IDF_PYTHON_ENV_PATH=
+ exec python /usr/share/${PN}/tools/idf.py \$@
+EOF
install_tool xtensa-esp-elf
install_tool xtensa-esp-elf/xtensa-esp-elf