aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuincy Fleming <quincyf467@protonmail.com>2023-07-16 22:08:47 -0500
committerQuincy Fleming <quincyf467@protonmail.com>2023-07-16 22:12:33 -0500
commitca7223caa969349f857703a845742880cc7098fd (patch)
treefbcc11047ccdb85864064f3a9e603034113285f8 /dev-embedded
parentdev-python/pysnooper: add 1.2.0 (diff)
downloadguru-ca7223caa969349f857703a845742880cc7098fd.tar.gz
guru-ca7223caa969349f857703a845742880cc7098fd.tar.bz2
guru-ca7223caa969349f857703a845742880cc7098fd.zip
dev-embedded/qdl: add 9999
Signed-off-by: Quincy Fleming <quincyf467@protonmail.com>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/qdl/qdl-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-embedded/qdl/qdl-9999.ebuild b/dev-embedded/qdl/qdl-9999.ebuild
new file mode 100644
index 000000000..f5fd68568
--- /dev/null
+++ b/dev-embedded/qdl/qdl-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3
+
+DESCRIPTION="Tool to communicate with Qualcomm System On a Chip bootroms"
+HOMEPAGE="https://github.com/andersson/qdl"
+EGIT_REPO_URI="https://github.com/andersson/qdl.git"
+
+LICENSE="BSD-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="virtual/libudev
+ dev-libs/libxml2
+"
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr install
+
+ dodoc README
+ insinto "/usr/share/${PN}"
+ doins LICENSE
+}