aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-15 22:36:51 +1300
committerTheo Anderson <telans@posteo.de>2020-12-15 22:40:54 +1300
commit0e91b97a94e587ec1de6e2efd60c130df2fe7a5d (patch)
tree47dede4e0ab98f8c297b5f99c2d93b66ca37329a /dev-lang
parentapp-misc/cheat: bump to 4.2.0 (diff)
downloadguru-0e91b97a94e587ec1de6e2efd60c130df2fe7a5d.tar.gz
guru-0e91b97a94e587ec1de6e2efd60c130df2fe7a5d.tar.bz2
guru-0e91b97a94e587ec1de6e2efd60c130df2fe7a5d.zip
dev-libs/wren: move to dev-lang/wren
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/wren/Manifest1
-rw-r--r--dev-lang/wren/metadata.xml19
-rw-r--r--dev-lang/wren/wren-0.2.0-r1.ebuild79
-rw-r--r--dev-lang/wren/wren-9999.ebuild79
4 files changed, 178 insertions, 0 deletions
diff --git a/dev-lang/wren/Manifest b/dev-lang/wren/Manifest
new file mode 100644
index 000000000..782d2d9f5
--- /dev/null
+++ b/dev-lang/wren/Manifest
@@ -0,0 +1 @@
+DIST wren-0.2.0.tar.gz 1791488 BLAKE2B a2f48e9b115ea89cf25af1fe8cefa3c26639ce06f89796df4f5eb744b2382b44f83d6285eedfa9cb5681342cc8ebca535bae586445225622c8ebdb30c7088975 SHA512 67912df14d8afa16a4e50fa67e232870e08eb392601f7b1633bcfb242f2de7624b9a3501df9e1ae40fb62646db57ff6553733ddb3015b6b5086999dadf7d2da2
diff --git a/dev-lang/wren/metadata.xml b/dev-lang/wren/metadata.xml
new file mode 100644
index 000000000..854f4ec84
--- /dev/null
+++ b/dev-lang/wren/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Wren is a small, fast, class-based concurrent scripting language
+ Think Smalltalk in a Lua-sized package with a dash of Erlang and wrapped up in a familiar, modern syntax.
+ </longdescription>
+ <maintainer type="person">
+ <email>m.santullo@posteo.net</email>
+ <name>Michele Santullo</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/wren-lang/wren/issues</bugs-to>
+ <remote-id type="github">wren-lang/wren</remote-id>
+ </upstream>
+ <use>
+ <flag name="tools">Install the wren command line interpreter</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-lang/wren/wren-0.2.0-r1.ebuild b/dev-lang/wren/wren-0.2.0-r1.ebuild
new file mode 100644
index 000000000..689c8a5dc
--- /dev/null
+++ b/dev-lang/wren/wren-0.2.0-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="The Wren Programming Language"
+HOMEPAGE="https://wren.io/"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/wren-lang/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/wren-lang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="static-libs tools"
+
+DEPEND=">=dev-libs/libuv-1.10.0"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+#BDEPEND="test? ( dev-lang/python )"
+#RESTRICT="!test? ( test )"
+RESTRICT="test"
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ local targets=""
+
+ if use static-libs ; then
+ #do both shared and static libs
+ targets="${targets} vm"
+ else
+ targets="${targets} shared"
+ fi
+ if use tools ; then
+ targets="${targets} cli"
+ fi
+ #I don't think tests are working, I just get lots of linker errors
+ #if use test ; then
+ # targets="${targets} api_test unit_test"
+ #fi
+
+ echo "prefix=\"${EPREFIX}/usr\"" > ${PN}.pc
+ echo "libdir=\"\${prefix}/$(get_libdir)\"" >> ${PN}.pc
+ echo "includedir=\"\${prefix}/include\"" >> ${PN}.pc
+ echo "" >> ${PN}.pc
+ echo "Name: ${PN}" >> ${PN}.pc
+ echo "Description: ${DESCRIPTION}" >> ${PN}.pc
+ echo "URL: ${HOMEPAGE}" >> ${PN}.pc
+ echo "Version: ${PV}" >> ${PN}.pc
+ echo "Libs: \"-L\${libdir}\" -l${PN}" >> ${PN}.pc
+ echo "Cflags: \"-I\${includedir}\"" >> ${PN}.pc
+
+ tc-export AR CC
+ emake -f util/wren.mk LIBUV_DIR="${EPREFIX}/usr" LIBUV="${EPREFIX}/usr/$(get_libdir)/libuv.so" VERBOSE=1 ${targets}
+}
+
+src_install() {
+ if use tools ; then
+ dobin bin/wren
+ fi
+ if use static-libs ; then
+ dolib.a lib/libwren.a
+ fi
+ dolib.so lib/libwren.so
+ doheader src/include/wren.h
+ doheader src/include/wren.hpp
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
+}
diff --git a/dev-lang/wren/wren-9999.ebuild b/dev-lang/wren/wren-9999.ebuild
new file mode 100644
index 000000000..689c8a5dc
--- /dev/null
+++ b/dev-lang/wren/wren-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="The Wren Programming Language"
+HOMEPAGE="https://wren.io/"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/wren-lang/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/wren-lang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="static-libs tools"
+
+DEPEND=">=dev-libs/libuv-1.10.0"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+#BDEPEND="test? ( dev-lang/python )"
+#RESTRICT="!test? ( test )"
+RESTRICT="test"
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ local targets=""
+
+ if use static-libs ; then
+ #do both shared and static libs
+ targets="${targets} vm"
+ else
+ targets="${targets} shared"
+ fi
+ if use tools ; then
+ targets="${targets} cli"
+ fi
+ #I don't think tests are working, I just get lots of linker errors
+ #if use test ; then
+ # targets="${targets} api_test unit_test"
+ #fi
+
+ echo "prefix=\"${EPREFIX}/usr\"" > ${PN}.pc
+ echo "libdir=\"\${prefix}/$(get_libdir)\"" >> ${PN}.pc
+ echo "includedir=\"\${prefix}/include\"" >> ${PN}.pc
+ echo "" >> ${PN}.pc
+ echo "Name: ${PN}" >> ${PN}.pc
+ echo "Description: ${DESCRIPTION}" >> ${PN}.pc
+ echo "URL: ${HOMEPAGE}" >> ${PN}.pc
+ echo "Version: ${PV}" >> ${PN}.pc
+ echo "Libs: \"-L\${libdir}\" -l${PN}" >> ${PN}.pc
+ echo "Cflags: \"-I\${includedir}\"" >> ${PN}.pc
+
+ tc-export AR CC
+ emake -f util/wren.mk LIBUV_DIR="${EPREFIX}/usr" LIBUV="${EPREFIX}/usr/$(get_libdir)/libuv.so" VERBOSE=1 ${targets}
+}
+
+src_install() {
+ if use tools ; then
+ dobin bin/wren
+ fi
+ if use static-libs ; then
+ dolib.a lib/libwren.a
+ fi
+ dolib.so lib/libwren.so
+ doheader src/include/wren.h
+ doheader src/include/wren.hpp
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
+}