aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2025-02-04 21:25:26 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2025-02-04 21:25:26 +0900
commit4c12a993fe18183eeeb83518b8ccf9bbe1d4bce3 (patch)
treec6737ff3029832056437b2062ccd0e6e35166701 /dev-lang
parentsys-boot/drbl: add missing BDEPEND (diff)
downloadguru-4c12a993fe18183eeeb83518b8ccf9bbe1d4bce3.tar.gz
guru-4c12a993fe18183eeeb83518b8ccf9bbe1d4bce3.tar.bz2
guru-4c12a993fe18183eeeb83518b8ccf9bbe1d4bce3.zip
dev-lang/odin: quote LLVM_SLOT with single quotes
LLVM_SLOT inside llvm_gen_dep() must not be expanded beforehand. Closes: https://bugs.gentoo.org/940461 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/odin/odin-2024.08.ebuild6
-rw-r--r--dev-lang/odin/odin-2024.09.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/odin/odin-2024.08.ebuild b/dev-lang/odin/odin-2024.08.ebuild
index 7e4822aee..4ff79d3f6 100644
--- a/dev-lang/odin/odin-2024.08.ebuild
+++ b/dev-lang/odin/odin-2024.08.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,10 +26,10 @@ SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
-$(llvm_gen_dep "
+$(llvm_gen_dep '
llvm-core/clang:${LLVM_SLOT}=
llvm-core/llvm:${LLVM_SLOT}=
-")
+')
"
DEPEND="${RDEPEND}"
diff --git a/dev-lang/odin/odin-2024.09.ebuild b/dev-lang/odin/odin-2024.09.ebuild
index 7e4822aee..4ff79d3f6 100644
--- a/dev-lang/odin/odin-2024.09.ebuild
+++ b/dev-lang/odin/odin-2024.09.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,10 +26,10 @@ SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
-$(llvm_gen_dep "
+$(llvm_gen_dep '
llvm-core/clang:${LLVM_SLOT}=
llvm-core/llvm:${LLVM_SLOT}=
-")
+')
"
DEPEND="${RDEPEND}"