aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-04-10 09:18:25 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-10 09:18:25 +0200
commit5cacbb6f4efadd9a20b8bf5ad81f306b4c6fc048 (patch)
treee1c49c1fdad2508cf62999785ce7f9aa02aa8009 /dev-lang
parentdev-lang/opencilk: add 2.1 (diff)
downloadguru-5cacbb6f4efadd9a20b8bf5ad81f306b4c6fc048.tar.gz
guru-5cacbb6f4efadd9a20b8bf5ad81f306b4c6fc048.tar.bz2
guru-5cacbb6f4efadd9a20b8bf5ad81f306b4c6fc048.zip
dev-lang/opencilk-bin: add 2.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/opencilk-bin/Manifest1
-rw-r--r--dev-lang/opencilk-bin/opencilk-bin-2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/opencilk-bin/Manifest b/dev-lang/opencilk-bin/Manifest
index d116e75d5..ba9556ddf 100644
--- a/dev-lang/opencilk-bin/Manifest
+++ b/dev-lang/opencilk-bin/Manifest
@@ -1 +1,2 @@
DIST OpenCilk-1.1-LLVM-12.0.0-Ubuntu-20.04-x86_64.tar.gz 785074089 BLAKE2B 1fa59979e025619ac19df8442705e8c44b5ee33dd2fed8d6531bc430909fb0b71685aa614a86532a50609b3d5a2d78719dd6720b3073cff0615c0fadf04bd5e7 SHA512 112f6a7033dfd010b7da01dad3221e54f8b46eeaede5d0afa95df07734c25fd063c9a651c3596d5cf15d214804d6cd381e05f26cb8b335a810daab985bf8c368
+DIST opencilk-2.1.0-x86_64-linux-gnu-ubuntu-22.04.tar.gz 1151431675 BLAKE2B 6449ab819733ac2bdace293764564e6d9dd890e10a033bd1a45fe669dc88ed15cd77539295f9294a1cf8cc84b5464c887c821fa4708c06765d98cb85902ba003 SHA512 bfa08acb8e135361e7611b2fc03811ea72736cdca84a7057220bf6696d7ff09dbc209d5b2b73775052b569ad5a921f458d60072c1029873121a330c3a7e32b77
diff --git a/dev-lang/opencilk-bin/opencilk-bin-2.1.ebuild b/dev-lang/opencilk-bin/opencilk-bin-2.1.ebuild
new file mode 100644
index 000000000..83671bf10
--- /dev/null
+++ b/dev-lang/opencilk-bin/opencilk-bin-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="The OpenCilk concurrency platform for parallel programming"
+HOMEPAGE="https://opencilk.org/"
+
+SRC_URI="https://github.com/OpenCilk/opencilk-project/releases/download/opencilk%2Fv${PV}/opencilk-${PV}.0-x86_64-linux-gnu-ubuntu-22.04.tar.gz"
+
+# Since opencilk-project is a fork of LLVM 12, this lists the licenses
+# of LLVM 12, while opencilk-project states that it us under "MIT with
+# the OpenCilk Addendum", which basically states that you can
+# distributed it under the LLVM licences. I am also not sure if OpenCilk
+# is able to change the license of LLVM (which source code they use),
+# hence this needs more investigation and we only list t he LLVM 12
+# licenses, because those definetly are correct.
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/ncurses:=
+ sys-libs/zlib
+"
+
+S="${WORKDIR}"
+
+QA_FLAGS_IGNORED="opt/${P}/.*"
+
+src_install() {
+ local target="opt/${P}"
+ dodir "${target}"
+ mv opencilk-2.1.0-x86_64-linux-gnu-ubuntu-22.04/* "${ED}/${target}" || die
+}