aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlain Emilia Anna Zscheile <fogti+devel@ytrizja.de>2024-02-26 13:42:37 +0100
committerDavid Roman <davidroman96@gmail.com>2024-03-02 11:55:25 +0100
commit194082673c4c662ca2717dc4ebbb099dec953e12 (patch)
tree08789c18adcebd284ab8a6ca84442e16441ee40c /dev-ml
parentdev-ml/*: remove empty RDEPEND lines (lint cleanup) (diff)
downloadguru-194082673c4c662ca2717dc4ebbb099dec953e12.tar.gz
guru-194082673c4c662ca2717dc4ebbb099dec953e12.tar.bz2
guru-194082673c4c662ca2717dc4ebbb099dec953e12.zip
dev-ml/*: version bump cstruct to 6.2.0, psq to 0.2.1
- cstruct: get rid of unnecessary ocaml-migrate-parsetree dependency O-M-PT is superseded by ppxlib, which already gets pulled in by the ppx useflag Signed-off-by: Alain Emilia Anna Zscheile <fogti+devel@ytrizja.de> Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cstruct/Manifest1
-rw-r--r--dev-ml/cstruct/cstruct-6.2.0.ebuild77
-rw-r--r--dev-ml/cstruct/files/6.2-ocaml-5.1.patch25
-rw-r--r--dev-ml/psq/Manifest1
-rw-r--r--dev-ml/psq/psq-0.2.1.ebuild26
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-ml/cstruct/Manifest b/dev-ml/cstruct/Manifest
index 15faa7e15..81ece4a90 100644
--- a/dev-ml/cstruct/Manifest
+++ b/dev-ml/cstruct/Manifest
@@ -1,2 +1,3 @@
DIST cstruct-6.0.1.tar.gz 243082 BLAKE2B 874ba34583bbc8b53c5b50ba038e2aa423fd704711194dcf99899239015d5fb383242b1d4654c1be2705fd80465e6da7e8eaa5265eceebca7b09dc036d4ebf40 SHA512 2f696b9dca1426d57f60fd4e997ee0c89b1af1a49e186e08c16911ceb03e9f89518a63faf4407b4a7e3c5f391d51979019e47a77f33961624d767a9e36146ca4
DIST cstruct-6.1.0.tar.gz 242509 BLAKE2B b41eb9b86830b7aef775f9bbfd0f08c29b495a032351ec38dd4553fb944e67a4875b7c2b7175761d78336a20782812148fd473075f4a3519b019f37a2c2ea7dc SHA512 eb1bcb6a35650f726f888c396f3ca64796ad16c1a7146130f8826004c3cac7e5bef2453821ca95844eaef4b4beab25e3db713e6a1a93f86986fb526f75a4e245
+DIST cstruct-6.2.0.tar.gz 244005 BLAKE2B bf6f63250eae360b842cbaa02ab23c287a2e44442cfc2a9cee69acc272cad16c23232375579e1123d46d389c627a995f8d04af56774cb91a7908b3b80d9ccb03 SHA512 064ea4a0ae039b9d177223e2bc886d6d3b16ab8e03a5cba3ef5f4d441bb2ef8e652971a467e592120a1bcb0a3fb74e1429664ee5017d707300a5723ba51d050f
diff --git a/dev-ml/cstruct/cstruct-6.2.0.ebuild b/dev-ml/cstruct/cstruct-6.2.0.ebuild
new file mode 100644
index 000000000..070bd7937
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-6.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="
+ https://github.com/mirage/ocaml-cstruct
+ https://opam.ocaml.org/packages/cstruct/
+"
+SRC_URI="https://github.com/mirage/ocaml-cstruct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ocaml-${P}"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async lwt ocamlopt ppx sexp test unix"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=dev-ml/fmt-0.8.9:=
+
+ async? (
+ >=dev-ml/async-0.9.0:=
+ >=dev-ml/async_unix-0.9.0:=
+ >=dev-ml/core-0.9.0:=
+ )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ >=dev-ml/ppxlib-0.16.0:=
+ dev-ml/stdlib-shims:=
+ )
+ sexp? ( >=dev-ml/sexplib-0.9.0:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/alcotest
+ dev-ml/crowbar
+ dev-ml/ppx_sexp_conv
+ dev-ml/cppo
+ >=dev-ml/lwt-2.0.2
+ )
+"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ ppx? ( sexp )
+ test? ( sexp ppx )
+"
+
+PATCHES=(
+ "${FILESDIR}/6.2-ocaml-5.1.patch"
+)
+
+src_compile() {
+ local pkgs="cstruct"
+ use ppx && pkgs="${pkgs},ppx_cstruct"
+ for u in async lwt sexp unix ; do
+ if use ${u} ; then
+ pkgs="${pkgs},cstruct-${u}"
+ fi
+ done
+ dune build -p "${pkgs}" -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ dune_src_install cstruct
+ for u in async lwt sexp unix ; do
+ if use ${u} ; then
+ dune_src_install "cstruct-${u}"
+ fi
+ done
+ use ppx && dune_src_install ppx_cstruct
+}
diff --git a/dev-ml/cstruct/files/6.2-ocaml-5.1.patch b/dev-ml/cstruct/files/6.2-ocaml-5.1.patch
new file mode 100644
index 000000000..ad0f08521
--- /dev/null
+++ b/dev-ml/cstruct/files/6.2-ocaml-5.1.patch
@@ -0,0 +1,25 @@
+diff --git a/ppx_cstruct.opam b/ppx_cstruct.opam
+index 264ad41..5c622fc 100644
+--- a/ppx_cstruct.opam
++++ b/ppx_cstruct.opam
+@@ -26,7 +26,6 @@ depends: [
+ "cstruct-sexp" {with-test}
+ "cppo" {with-test}
+ "cstruct-unix" {with-test & =version}
+- "ocaml-migrate-parsetree" {>= "2.1.0" & with-test}
+ "lwt_ppx" {>= "2.0.2" & with-test}
+ ]
+ synopsis: "Access C-like structures directly from OCaml"
+diff --git a/ppx_test/errors/dune b/ppx_test/errors/dune
+index ed51ce0..0712dc9 100644
+--- a/ppx_test/errors/dune
++++ b/ppx_test/errors/dune
+@@ -4,7 +4,7 @@
+ (preprocess
+ (action
+ (run %{bin:cppo} -V OCAML:%{ocaml_version} %{input-file})))
+- (libraries ppx_cstruct ocaml-migrate-parsetree))
++ (libraries ppx_cstruct))
+
+ (executable
+ (name gen_tests)
diff --git a/dev-ml/psq/Manifest b/dev-ml/psq/Manifest
index 8914696b1..ff9b3259c 100644
--- a/dev-ml/psq/Manifest
+++ b/dev-ml/psq/Manifest
@@ -1 +1,2 @@
+DIST psq-0.2.1.tbz 11341 BLAKE2B c689885bc91aa1e2969009f9158597bf7562b0240ff124cdb06ccb55c43d296092c17df50b26714a0165e417b840a20035c399e4479a4c1dbf53dd71205ed597 SHA512 8a8dfe20dc77e1cf38a7b1a7fc76f815c71a4ffe04627151b855feaba8f1ae742594739d1b7a45580b5b24a2cd99b58516f6b5c8d858aa314201f4a6422101ee
DIST psq-v0.2.0.tbz 10538 BLAKE2B 87626e0cac63b27d114c0497709d2b4cea55df4045b2033d5104bfacdb67b5286bcdf379a7f68936e852cd0f1260deb2258d0792691d32db406162dd3453e2d4 SHA512 0c570c5fc2bb2348b1ec03507abb4f152673a5d8f92c388c4cd5b7fc43a6e8f514007dbf4fb613503c4e8d5c8d3210b24ac37c546c79d94ebdf6b482e5cde024
diff --git a/dev-ml/psq/psq-0.2.1.ebuild b/dev-ml/psq/psq-0.2.1.ebuild
new file mode 100644
index 000000000..031ea9309
--- /dev/null
+++ b/dev-ml/psq/psq-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Functional Priority Search Queues for OCaml"
+HOMEPAGE="https://github.com/pqwy/psq"
+SRC_URI="https://github.com/pqwy/psq/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="dev-ml/seq:="
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/qcheck:*
+ dev-ml/alcotest:*
+ )
+"
+
+RESTRICT="!test? ( test )"