aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-24 19:11:58 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-24 19:36:40 +0200
commit777661746dddac4558a83fe02d122d218b9aad4d (patch)
treec9e4de9c56f2e33ff1269e5df779723e2f6abc36 /dev-ml
parentdev-ml/mirage-crypto: add 0.10.6 (diff)
downloadguru-777661746dddac4558a83fe02d122d218b9aad4d.tar.gz
guru-777661746dddac4558a83fe02d122d218b9aad4d.tar.bz2
guru-777661746dddac4558a83fe02d122d218b9aad4d.zip
dev-ml/mirage-crypto: drop 0.10.1
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/mirage-crypto/Manifest1
-rw-r--r--dev-ml/mirage-crypto/mirage-crypto-0.10.1.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-ml/mirage-crypto/Manifest b/dev-ml/mirage-crypto/Manifest
index ba660d0b8..86da4fa1e 100644
--- a/dev-ml/mirage-crypto/Manifest
+++ b/dev-ml/mirage-crypto/Manifest
@@ -1,3 +1,2 @@
DIST mirage-crypto-0.10.6.tbz 1206906 BLAKE2B 7b6d6a323b0aa6f2a0328d8817bd4447c00083127b8b277ce7d10b952841b8554278d37b48e936b05bd6a04117960241d6f4bf7d1c00a3ba364ec2c3c8535162 SHA512 870b7d0d32acde970afcd3fac2cb51131ac74bb20c887d07ddfccd239467a5dc8b700adf463427fa916393c503f106feb733cba5bf4b9d1f8eb57f52b5af9f9c
-DIST mirage-crypto-v0.10.1.tbz 1200115 BLAKE2B 4a7557adb0e16834a6e298fb52f40b85e67cde44fdc04607dfd46a8a29a1957e1a61bfcec1c35f80477e1319dc2fe850fc65aac3c07ba9b706e6cfdec563a0e6 SHA512 08ba60ae7cc0e0c77b4d71fa05241bfd2e47bfb907cf7e1a4f6bd8bf62854ee82becd2f4e65eade1a01b58d91fb33829f4f69b39e8910df9cfeaa87c933a336d
DIST mirage-crypto-v0.10.5.tbz 1207228 BLAKE2B bea0dc169c9ae79196ab4f74b624f191a45f051b8cf0c3774d4eb7323f1139d1e7e78b59f46c986bffba4c570c408d9d4f8db19cce4f6d4b233aa00d00f7ec04 SHA512 18b493be1e7909e8429bc5ddd1f0d1175aab9e21a10711e95749b74f1d9f851a5cfd3ee1a5b3b73a47b5fc54d6458a911ec586ab243e63bf276d2777a787ae51
diff --git a/dev-ml/mirage-crypto/mirage-crypto-0.10.1.ebuild b/dev-ml/mirage-crypto/mirage-crypto-0.10.1.ebuild
deleted file mode 100644
index 29c57a47b..000000000
--- a/dev-ml/mirage-crypto/mirage-crypto-0.10.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune multiprocessing
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Simple symmetric cryptography for the modern age"
-HOMEPAGE="https://github.com/mirage/mirage-crypto"
-SRC_URI="https://github.com/mirage/mirage-crypto/releases/download/v${PV}/${MY_P}.tbz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="ec ocamlopt pk rng rng-async rng-mirage test"
-
-DEPEND="
- dev-ml/cstruct:=
- dev-ml/eqaf:=
-
- pk? (
- dev-libs/gmp
- dev-ml/mirage:=
- dev-ml/sexplib0:=
- dev-ml/zarith:=
- )
- rng? (
- dev-ml/duration:=
- dev-ml/logs:=
- )
- rng-async? ( dev-ml/async:= )
- rng-mirage? (
- dev-ml/lwt:=
- dev-ml/mirage:=
- dev-ml/mirage-clock:=
- dev-ml/mirage-time:=[unix]
- dev-ml/mirage-unix:=
- )
-"
-RDEPEND="
- ${DEPEND}
- test? (
- dev-ml/ounit2
- dev-ml/randomconv
- dev-ml/hex
- dev-ml/asn1-combinators
- dev-ml/ppx_deriving
- dev-ml/ppx_deriving_yojson
- dev-ml/yojson
- dev-ml/alcotest
- dev-ml/mirage-clock-unix
- )
-"
-BDEPEND="
- dev-ml/dune-configurator
- virtual/pkgconfig
-"
-
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- test? ( ec pk rng )
- ec? ( rng )
- pk? ( rng )
- rng-async? ( rng )
- rng-mirage? ( rng )
-"
-
-src_compile() {
- local pkgs="mirage-crypto"
- for u in rng rng-async rng-mirage pk ec ; do
- if use ${u} ; then
- pkgs="${pkgs},mirage-crypto-${u}"
- fi
- done
- dune build -p "${pkgs}" -j $(makeopts_jobs) || die
-}
-
-src_install() {
- dune_src_install mirage-crypto
- use rng && dune_src_install mirage-crypto-rng
- use ec && dune_src_install mirage-crypto-ec
- use pk && dune_src_install mirage-crypto-pk
- use rng-async && dune_src_install mirage-crypto-rng-async
- use rng-mirage && dune_src_install mirage-crypto-rng-mirage
-}