aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <WolfgangESanyer@gmail.com>2021-01-03 21:02:06 -0500
committerWolfgang E. Sanyer <WolfgangESanyer@gmail.com>2021-01-03 21:14:53 -0500
commitec6a473f4f3c62a4a306e84414ea5f2ce16e73f3 (patch)
treede839773ee2f6f861b9566b492aab7584f285b09 /dev-python/b2sdk
parentdev-python/phx-class-registry: new package, dep of b2 (diff)
downloadguru-ec6a473f4f3c62a4a306e84414ea5f2ce16e73f3.tar.gz
guru-ec6a473f4f3c62a4a306e84414ea5f2ce16e73f3.tar.bz2
guru-ec6a473f4f3c62a4a306e84414ea5f2ce16e73f3.zip
dev-python/b2sdk: new package, dep of b2
Signed-off-by: Wolfgang E. Sanyer <WolfgangESanyer@gmail.com>
Diffstat (limited to 'dev-python/b2sdk')
-rw-r--r--dev-python/b2sdk/Manifest1
-rw-r--r--dev-python/b2sdk/b2sdk-1.2.0.ebuild36
-rw-r--r--dev-python/b2sdk/files/b2sdk-1.2.0-skip-integration-test.patch12
-rw-r--r--dev-python/b2sdk/metadata.xml14
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/b2sdk/Manifest b/dev-python/b2sdk/Manifest
new file mode 100644
index 000000000..117886c8d
--- /dev/null
+++ b/dev-python/b2sdk/Manifest
@@ -0,0 +1 @@
+DIST b2sdk-1.2.0.tar.gz 172456 BLAKE2B 7af232d1bb274037b327a7a0740ca7ea8f1a8edda26bd6816fe66bc332c69c9ba3f95c790f8d1c799391548ff7a7b190603ed3c358512401c0cdec5d9c93c72c SHA512 05273de5d83a62afe33873ddd66f22005bcfbd559314d43a5662981e024f18063eeee078d00b42b407aeda331083c826c4c6fc4e06cad280b280de8cb66423d2
diff --git a/dev-python/b2sdk/b2sdk-1.2.0.ebuild b/dev-python/b2sdk/b2sdk-1.2.0.ebuild
new file mode 100644
index 000000000..9967cecdc
--- /dev/null
+++ b/dev-python/b2sdk/b2sdk-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+inherit distutils-r1
+
+DESCRIPTION="The client library for BackBlaze's B2 product"
+HOMEPAGE="https://github.com/Backblaze/b2-sdk-python"
+SRC_URI="https://github.com/Backblaze/b2-sdk-python/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.0-skip-integration-test.patch"
+)
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/arrow-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/logfury-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.5.0[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest
+
+BDEPEND+=" test? (
+ $(python_gen_cond_dep '
+ >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
+ ')
+)"
diff --git a/dev-python/b2sdk/files/b2sdk-1.2.0-skip-integration-test.patch b/dev-python/b2sdk/files/b2sdk-1.2.0-skip-integration-test.patch
new file mode 100644
index 000000000..bd13d9944
--- /dev/null
+++ b/dev-python/b2sdk/files/b2sdk-1.2.0-skip-integration-test.patch
@@ -0,0 +1,12 @@
+diff --git a/test/integration/test_raw_api.py b/test/integration/test_raw_api.py
+index e6cd288..ec89604 100644
+--- a/test/integration/test_raw_api.py
++++ b/test/integration/test_raw_api.py
+@@ -15,6 +15,7 @@ from b2sdk import raw_api
+
+
+ # TODO: move the test_raw_api test logic here
++@pytest.mark.skip(reason="Cannot do this in portage")
+ def test_raw_api():
+ application_key_id = os.environ.get('B2_TEST_APPLICATION_KEY_ID')
+ if application_key_id is None:
diff --git a/dev-python/b2sdk/metadata.xml b/dev-python/b2sdk/metadata.xml
new file mode 100644
index 000000000..77c569d1e
--- /dev/null
+++ b/dev-python/b2sdk/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>WolfgangESanyer@gmail.com</email>
+ <name>Wolfgang E. Sanyer</name>
+ </maintainer>
+ <longdescription lang="en">
+ The command-line tool that gives easy access to all of the capabilities
+ of B2 Cloud Storage.
+
+ This program provides command-line access to the B2 service.
+ </longdescription>
+</pkgmetadata>