aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:20:02 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:29:03 +0200
commit8a000ba421740a784b25c855bcf4b89e0df9766e (patch)
tree6f68219ffb6480b3ec49b85c2a20e74fd2841bf8 /dev-python/pytest-benchmark
parentdev-python/hunter: new package (diff)
downloadguru-8a000ba421740a784b25c855bcf4b89e0df9766e.tar.gz
guru-8a000ba421740a784b25c855bcf4b89e0df9766e.tar.bz2
guru-8a000ba421740a784b25c855bcf4b89e0df9766e.zip
dev-python/pytest-benchmark: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/pytest-benchmark')
-rw-r--r--dev-python/pytest-benchmark/Manifest1
-rw-r--r--dev-python/pytest-benchmark/metadata.xml23
-rw-r--r--dev-python/pytest-benchmark/pytest-benchmark-3.2.3.ebuild41
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pytest-benchmark/Manifest b/dev-python/pytest-benchmark/Manifest
new file mode 100644
index 000000000..e0224b528
--- /dev/null
+++ b/dev-python/pytest-benchmark/Manifest
@@ -0,0 +1 @@
+DIST pytest-benchmark-3.2.3.tar.gz 321127 BLAKE2B a9fb3a01ac9850d813f9b72d1975010b63b4f9d35d48c683b8dfa5d0020b17c59339135ff63b6152efab3ac33fecbc09aacbe6bcc3a7b0b260a00da317db00bf SHA512 952dbe2a9af1ae5de966543eae3b4523a5418c8441785714cbb7a5d17697046f060befb4a40cf216526e2a9a63d91c598d65e65618bd78fc2d889c92cecbbe53
diff --git a/dev-python/pytest-benchmark/metadata.xml b/dev-python/pytest-benchmark/metadata.xml
new file mode 100644
index 000000000..707882f3b
--- /dev/null
+++ b/dev-python/pytest-benchmark/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+ This plugin tightly integrates into pytest. To use this effectively you should know a thing or two about pytest first. Take a look at the introductory material or watch talks.
+
+ Few notes:
+
+ This plugin benchmarks functions and only that. If you want to measure block of code or whole programs you will need to write a wrapper function.
+ In a test you can only benchmark one function. If you want to benchmark many functions write more tests or use parametrization http://docs.pytest.org/en/latest/parametrize.html.
+ To run the benchmarks you simply use pytest to run your "tests". The plugin will automatically do the benchmarking and generate a result table. Run pytest --help for more details.
+
+This plugin provides a benchmark fixture. This fixture is a callable object that will benchmark any function passed to it.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ionelm/pytest-benchmark</remote-id>
+ <remote-id type="pypi">pytest-benchmark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-benchmark/pytest-benchmark-3.2.3.ebuild b/dev-python/pytest-benchmark/pytest-benchmark-3.2.3.ebuild
new file mode 100644
index 000000000..82b9e642b
--- /dev/null
+++ b/dev-python/pytest-benchmark/pytest-benchmark-3.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+#DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test fixture for benchmarking code "
+HOMEPAGE="
+ https://pypi.python.org/pypi/pytest-benchmark
+ https://github.com/ionelmc/pytest-benchmark
+"
+SRC_URI="https://github.com/ionelmc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/py-cpuinfo[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/aspectlib[${PYTHON_USEDEP}]
+ dev-python/elasticsearch-py[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hunter[${PYTHON_USEDEP}]
+ dev-python/pygal[${PYTHON_USEDEP}]
+ dev-python/pygaljs[${PYTHON_USEDEP}]
+ dev-python/pytest-instafail[${PYTHON_USEDEP}]
+ dev-python/pytest-travis-fold[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme