aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-09-12 14:04:21 +0200
committerDavid Roman <davidroman96@gmail.com>2024-09-12 14:04:32 +0200
commit06494baffc73322bf1407b091d726f141b7cfd17 (patch)
tree6452cbf11737b2d4dadcd0a6f8994c9318a7adfa /dev-python/python-statemachine
parentdev-python/python-statemachine: add 2.3.6 (diff)
downloadguru-06494baffc73322bf1407b091d726f141b7cfd17.tar.gz
guru-06494baffc73322bf1407b091d726f141b7cfd17.tar.bz2
guru-06494baffc73322bf1407b091d726f141b7cfd17.zip
dev-python/python-statemachine: drop 2.3.3, 2.3.4
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python/python-statemachine')
-rw-r--r--dev-python/python-statemachine/Manifest2
-rw-r--r--dev-python/python-statemachine/python-statemachine-2.3.3.ebuild48
-rw-r--r--dev-python/python-statemachine/python-statemachine-2.3.4.ebuild48
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/python-statemachine/Manifest b/dev-python/python-statemachine/Manifest
index 363600b19..5dba15a33 100644
--- a/dev-python/python-statemachine/Manifest
+++ b/dev-python/python-statemachine/Manifest
@@ -1,4 +1,2 @@
-DIST python-statemachine-2.3.3.gh.tar.gz 347194 BLAKE2B 02372cee9105d09d9cbb57492ebb73bd15e68fa01bed70453c24d51385b2a9f4e3edc6b9f93ceca738486e3a0974a2527ff1b63873b1fcd033fb5870ecd66e10 SHA512 ccd0133e55332fe8511150ef34408e01412de5ce06357b0bb1a3c3ad18ccb1c28753f2ebf3ad2a20391e2df0f76d2dd673db0fd0301862993f8116326d32eae6
-DIST python-statemachine-2.3.4.gh.tar.gz 350704 BLAKE2B 3cac223e6252d61d7bab2952491802bd60e1dad5dd564f121fc6a46a721eb44bd708310352f9d1d9d1d47948aa1bda8ae6ac0acdbb8b129ddc4b6ad58420921f SHA512 ac478c29cbc0c426b93ba37be3453d3f6d1f2c5a5046369c201488f5fc9a6cd8d2e9712a061c50a4f413fffa7650f74c6d358429c8ddd96b72ec07da17497ada
DIST python-statemachine-2.3.5.gh.tar.gz 350690 BLAKE2B 8a16722b62d07df47d15b32374575ba3beb3a575ad55507cee7b1b8e58c6a35635c8571a25b5cae1d56167736f38101fdf099b725f19ae6adde8ef5641c372ac SHA512 1a9dbd3e835ecfaa46f0aff8d487836962f4ba1856a64ab3f02976871a91713193cda16faa817ae1cfd4a94e42cad22f6d896d3b57b63128d85ea0bba8e5f44c
DIST python-statemachine-2.3.6.gh.tar.gz 351057 BLAKE2B 03d605b0389dd9fac3e2d8a979295ab7724a79b2b1e677cbd114d8eddaa9a987f361aebbea29eb670930fd7978cb1d9f59ef2a40ec98f9c515d080fcc902f25c SHA512 cc8400a118da6d54b97108ff8b11462aee32dc28ada97fbf2a68049de2659c5a7faaa24802fab376b72586c1052db13b67b570a5d62eb9c28252572d14634215
diff --git a/dev-python/python-statemachine/python-statemachine-2.3.3.ebuild b/dev-python/python-statemachine/python-statemachine-2.3.3.ebuild
deleted file mode 100644
index d2640619b..000000000
--- a/dev-python/python-statemachine/python-statemachine-2.3.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{11,12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Finite State Machines made easy."
-HOMEPAGE="
- https://pypi.org/project/python-statemachine/
- https://github.com/fgmacedo/python-statemachine
-"
-SRC_URI="https://github.com/fgmacedo/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/pydot[${PYTHON_USEDEP}]"
-
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- tests/test_mixins.py::test_mixin_should_instantiate_a_machine
-)
-
-EPYTEST_IGNORE=(
- tests/test_profiling.py
- tests/django_project/workflow/tests.py
-)
-
-python_test() {
- epytest -o 'addopts=""'
-
-}
diff --git a/dev-python/python-statemachine/python-statemachine-2.3.4.ebuild b/dev-python/python-statemachine/python-statemachine-2.3.4.ebuild
deleted file mode 100644
index d2640619b..000000000
--- a/dev-python/python-statemachine/python-statemachine-2.3.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{11,12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Finite State Machines made easy."
-HOMEPAGE="
- https://pypi.org/project/python-statemachine/
- https://github.com/fgmacedo/python-statemachine
-"
-SRC_URI="https://github.com/fgmacedo/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/pydot[${PYTHON_USEDEP}]"
-
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- tests/test_mixins.py::test_mixin_should_instantiate_a_machine
-)
-
-EPYTEST_IGNORE=(
- tests/test_profiling.py
- tests/django_project/workflow/tests.py
-)
-
-python_test() {
- epytest -o 'addopts=""'
-
-}