aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-06-20 07:28:49 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-06-20 07:28:49 +0300
commitd21398ca9b847f62f0de614459b291fd82fa52cd (patch)
tree2a3613fb68d698f436bb85b87aa6498e49365897 /dev-python/survey
parentapp-misc/anki-bin: add 24.06.2 (diff)
downloadguru-d21398ca9b847f62f0de614459b291fd82fa52cd.tar.gz
guru-d21398ca9b847f62f0de614459b291fd82fa52cd.tar.bz2
guru-d21398ca9b847f62f0de614459b291fd82fa52cd.zip
dev-python/survey: add 5.4.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-python/survey')
-rw-r--r--dev-python/survey/Manifest1
-rw-r--r--dev-python/survey/survey-5.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/survey/Manifest b/dev-python/survey/Manifest
index 8311de32f..b3e278ff9 100644
--- a/dev-python/survey/Manifest
+++ b/dev-python/survey/Manifest
@@ -1,2 +1,3 @@
DIST survey-4.5.4.tar.gz 831109 BLAKE2B 00065211437f4c6c820aca5c511395625da7be9415218d6261005aff946b19a3e65cc31189a6aef755ed88ce81f309ac2eabe23ea7f1e2f359007b4fe9172f96 SHA512 045989ca95e3fa9a840ad8d37a040f46bf3f22a858dd7b826fecf88d4e53b6b14e285ef3bf266add496da2d5ffd58971c2456b4375362e24c1a071fc910a03f4
DIST survey-5.3.1.gh.tar.gz 1564902 BLAKE2B de8bafd2fc5a683ca0364f9e1540e177bf2f10344406563ff3ef6723abd2c415517e72ffacccae51e1d69912b966bf678c2abc62b22545f1c5871d4f3459d121 SHA512 383d7339e93760294095881b6ebf3fd00d687210865303aa2c17a51a390f8087b8666364e0ba7b7657e009803665cf02e64f280c8a09a535ce1fa1ebeaafe963
+DIST survey-5.4.0.gh.tar.gz 1565353 BLAKE2B f020637b23274314539ee1e81c86ba49b98b226bc2f3ebf4ff6373229785d5ba5a9681656ef0165e6ea1801f183b59f3ad6b58667d2e5d263fdbe5ee501ba90a SHA512 7821e96d4f01b275f3f8fdb396167205f04200c0331b9ccdc9970da2ffb239431ef2b1f24fa1714f9b902402abf3c5258aa0d4758335623e71200b5929440609
diff --git a/dev-python/survey/survey-5.4.0.ebuild b/dev-python/survey/survey-5.4.0.ebuild
new file mode 100644
index 000000000..5d68e2cb2
--- /dev/null
+++ b/dev-python/survey/survey-5.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A simple library for creating beautiful interactive prompts"
+HOMEPAGE="
+ https://github.com/Exahilosys/survey
+ https://pypi.org/project/survey/
+"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/Exahilosys/survey/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-paramlinks \
+ dev-python/sphinx-rtd-theme
+
+src_configure() {
+ distutils-r1_src_configure
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}