aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-07-18 03:28:17 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-07-18 04:00:19 +0500
commit82a66c40fa05a392ec21e04b77f21ce939817358 (patch)
tree958f8236c2b4e9a8e28daba5d64f9b700e69e605 /dev-python
parentdev-python/mkdocs-swagger-ui-tag: treeclean masked (diff)
downloadguru-82a66c40fa05a392ec21e04b77f21ce939817358.tar.gz
guru-82a66c40fa05a392ec21e04b77f21ce939817358.tar.bz2
guru-82a66c40fa05a392ec21e04b77f21ce939817358.zip
dev-python/pysaml2: drop 7.1.2, add 7.4.2
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysaml2/Manifest2
-rw-r--r--dev-python/pysaml2/pysaml2-7.1.2-r1.ebuild47
-rw-r--r--dev-python/pysaml2/pysaml2-7.4.2.ebuild43
3 files changed, 44 insertions, 48 deletions
diff --git a/dev-python/pysaml2/Manifest b/dev-python/pysaml2/Manifest
index 6b1504666..2d286b086 100644
--- a/dev-python/pysaml2/Manifest
+++ b/dev-python/pysaml2/Manifest
@@ -1 +1 @@
-DIST pysaml2-7.1.2.gh.tar.gz 6017150 BLAKE2B e14bff119e5f6e477244820887ed76531acad5d7207cfc6ca398eaeaa0f5649e168bd6322d50e29560e8ad78e8da66d47b9d293ffcedee4358e288640931df96 SHA512 cf13ef0f74785bac357b2871f1ab521e60720cb236881fbc6c93d0eaca5323d198952392fa8a13850060a54757b1ff06a959e723bc7aeb5db9c8b2522b3c859b
+DIST pysaml2-7.4.2.gh.tar.gz 6059879 BLAKE2B 46e319b288f792c2bf352dfaca507b24a1d23e1f4e7d1cc85685cc82a38103d113a6ec6d5d31608a226873cc5dab774689625f0437146befc43a33cafe641e78 SHA512 4a125cf08e7eb4856aea87eb7cad0539b1e520d44cf7a6a6fcb52185ab2acf05efe773165614f9b633c85f46ca4b189ee6038aaa51fe8343d75ab3bf0e06d43e
diff --git a/dev-python/pysaml2/pysaml2-7.1.2-r1.ebuild b/dev-python/pysaml2/pysaml2-7.1.2-r1.ebuild
deleted file mode 100644
index 685a28023..000000000
--- a/dev-python/pysaml2/pysaml2-7.1.2-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
-HOMEPAGE="https://github.com/rohe/pysaml2"
-SRC_URI="https://github.com/IdentityPython/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/cryptography-1.4[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- dev-python/xmlsec[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/pymongo-3[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # No module named 'pymongo.mongo_replica_set_client' because pymongo should be <4 but we only have >=4
- rm tests/test_{75_mongodb,76_metadata_in_mdb}.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/pysaml2/pysaml2-7.4.2.ebuild b/dev-python/pysaml2/pysaml2-7.4.2.ebuild
new file mode 100644
index 000000000..3cffc8c30
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-7.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 Standard"
+HOMEPAGE="
+ https://pypi.org/project/pysaml2/
+ https://github.com/rohe/pysaml2
+"
+SRC_URI="https://github.com/IdentityPython/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/xmlsec[openssl]
+ >=dev-python/cryptography-3.1[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/xmlschema-1.2.1[${PYTHON_USEDEP}]
+"
+# TODO: package 'repoze-who' for s2repoze tests
+BDEPEND="
+ test? (
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ <dev-python/pymongo-5[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/alabaster