aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-07-18 12:07:59 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-07-18 12:07:59 +0300
commitcafd00fd1d6598e9fca752a17380cc3f3e39331e (patch)
tree306f8b511aa9180aad678f914d6ed53b86c261fb /dev-python
parentdev-embedded/esp-idf: drop 5.0.2, 5.0.2-r1 (diff)
downloadguru-cafd00fd1d6598e9fca752a17380cc3f3e39331e.tar.gz
guru-cafd00fd1d6598e9fca752a17380cc3f3e39331e.tar.bz2
guru-cafd00fd1d6598e9fca752a17380cc3f3e39331e.zip
dev-python/survey: add 4.5.2
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/survey/Manifest1
-rw-r--r--dev-python/survey/survey-4.5.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/survey/Manifest b/dev-python/survey/Manifest
index 4d09434b9..66653a008 100644
--- a/dev-python/survey/Manifest
+++ b/dev-python/survey/Manifest
@@ -1,2 +1,3 @@
DIST survey-3.4.3.tar.gz 21219 BLAKE2B e866addd9233409c603f2b34bbf811209f3f6c2ade1bee00258c4f25d741dc526948d16b2e9e0dc3632e6e20fa7863f573c4c27ed1f48ddaa954c7d53a8c51e3 SHA512 47ff72dd1223a32ec038ccf57709e8fe64806ecc9bb8e54daaced27afaa1c2a45e76fc1b149232a107729c462db7657ad0fd08d8b14bb314e3905aabd23fff4a
DIST survey-4.5.1.tar.gz 830756 BLAKE2B 11fd1e2fd0da550178a043bc698c09b39cd2b6f84ee562a8476cb204802927f22d9a21110fd9134828c593b888a1052b48105d04458fe7630faadd5b079e0669 SHA512 14f4026ecb845c3ad252c485fed049a10ee854cdd3940f3fae3a0bd4cd077c55f2bc11b9480e8e6d1e6572c63654228b7a56b36c37c90f63cf5c2c0c65263e6f
+DIST survey-4.5.2.tar.gz 830754 BLAKE2B 32fdcdede0113d4ef05492cddc047925d93f385db309eed6c7a1cb1279c6c92a2ecc69c5ecf7361545eb3ccf4e4685f4e8d0344d2c2cf4392a8c7c635f714f27 SHA512 f011df6a75d074f2543311eee332a0d43436bbd6b29ed491028510a5df9d70502e8f96f18afebe513446bc26623bed292bfcecf1b52e93f3d4838b1f70ff705d
diff --git a/dev-python/survey/survey-4.5.2.ebuild b/dev-python/survey/survey-4.5.2.ebuild
new file mode 100644
index 000000000..5394b397d
--- /dev/null
+++ b/dev-python/survey/survey-4.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple library for creating beautiful interactive prompts"
+HOMEPAGE="
+ https://github.com/Exahilosys/survey
+ https://pypi.org/project/survey/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-paramlinks \
+ dev-python/sphinx-rtd-theme