aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2023-02-20 18:58:54 +0100
committerAlexey Zapparov <alexey@zapparov.com>2023-02-20 18:59:12 +0100
commita30fc20bd2f4bf4387263c5a465702cd57785d01 (patch)
treece9e05694c0b7148611923795c83275cfd43765a /dev-ruby
parentgui-apps/intiface-central-bin: new package, add 2.3.0 (diff)
downloadguru-a30fc20bd2f4bf4387263c5a465702cd57785d01.tar.gz
guru-a30fc20bd2f4bf4387263c5a465702cd57785d01.tar.bz2
guru-a30fc20bd2f4bf4387263c5a465702cd57785d01.zip
dev-ruby/ruby-install: add 0.9.0
Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-install/Manifest1
-rw-r--r--dev-ruby/ruby-install/ruby-install-0.9.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/ruby-install/Manifest b/dev-ruby/ruby-install/Manifest
index 90971b07a..534467661 100644
--- a/dev-ruby/ruby-install/Manifest
+++ b/dev-ruby/ruby-install/Manifest
@@ -1,2 +1,3 @@
DIST ruby-install-0.8.4.tar.gz 32652 BLAKE2B e863645c66cc631d17a3e5c061220fd59d0b0458613d31e8db4d35fbb0beae53ccf627620b9adb08bb0db82d51bd9a54a7eb96079fc3e6604c32d9b7dc219f3d SHA512 9d7157ab73689a7024efae104f6fd244c019c56d5e27573151818dd72f07855f9785b2ddba9c83a413ddcd92a565893373ca545c486c59b4fa408f349d4c7f48
DIST ruby-install-0.8.5.tar.gz 32904 BLAKE2B 6128d489c53c02b53b96f243a7c5fd3de2a360eac8ed7873c89cfafb229e611f77f3275e66bb1aef0ccad772029f7727c0e4a62c6dc74ec1780c7badd219cc52 SHA512 4f5546652e741eb4b1b72780a73e0b41b8bd212dd979e31124b8a1a96e9bbebdcb7951da20768b992776206a446b489214f2b1261255855760e2e3477118f8d7
+DIST ruby-install-0.9.0.tar.gz 34536 BLAKE2B de44b380b47f1c194bd9c39e43527c48b61f051bc126b051d87ce23db7d5ed3c6f46a97ff454e847a47fe16535c15d5903839f07ed30446f0b2f0d063364961b SHA512 d40195519d4d49749e13fb9d1c2e8f6a4c4c7b1cb4c419ce737a2dc2f7f6fb80b0783626bfe4b4bdd642a189d6fd641a5a121a4fa661e8a7539b4eefa12435ae
diff --git a/dev-ruby/ruby-install/ruby-install-0.9.0.ebuild b/dev-ruby/ruby-install/ruby-install-0.9.0.ebuild
new file mode 100644
index 000000000..6316a7848
--- /dev/null
+++ b/dev-ruby/ruby-install/ruby-install-0.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Installs Ruby, JRuby, Rubinius, TruffleRuby (native / GraalVM), or mruby."
+HOMEPAGE="https://github.com/postmodern/ruby-install"
+SRC_URI="https://github.com/postmodern/ruby-install/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PROPERTIES="test_network"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-shells/bash-3.0:*"
+RDEPEND="${DEPEND}
+ sys-apps/grep
+ || ( >net-misc/wget-1.12 net-misc/curl )
+ dev-libs/openssl
+ app-arch/tar
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-devel/patch
+ || ( >=sys-devel/gcc-4.2 sys-devel/clang )"
+BDEPEND="test? ( dev-util/shunit2 )"
+
+# BUG: `make check` fails: https://github.com/postmodern/ruby-install/issues/442
+src_test() {
+ emake test
+}
+
+src_prepare() {
+ default
+
+ sed -i Makefile -e "s/^VERSION=.\+$/VERSION=${PVR}/" \
+ || die "Cannot fix doc location to follow Gentoo/FHS guidelines"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}