aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-17 17:47:02 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-17 17:48:04 +0900
commit14649a97ea233699ddbc71f2c27a26af508eecb1 (patch)
tree58bb177401ffcddbbeb1846a62aed1ce656c79e9 /games-fps
parentgames-fps/crispy-doom: Remove unnecessary bash-completion dependency (diff)
downloadguru-14649a97ea233699ddbc71f2c27a26af508eecb1.tar.gz
guru-14649a97ea233699ddbc71f2c27a26af508eecb1.tar.bz2
guru-14649a97ea233699ddbc71f2c27a26af508eecb1.zip
games-fps/gzdoom: version bump to 4.1.2
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/gzdoom/Manifest1
-rw-r--r--games-fps/gzdoom/gzdoom-4.1.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/games-fps/gzdoom/Manifest b/games-fps/gzdoom/Manifest
index 21c397636..829f13499 100644
--- a/games-fps/gzdoom/Manifest
+++ b/games-fps/gzdoom/Manifest
@@ -1 +1,2 @@
DIST gzdoom-4.1.1.tar.gz 13008847 BLAKE2B ac2bddbcc618148ed9de15dfe9105d1f3b9f319496b995d2af06834eb1349415ab3ee48beaa3e1acac04c81152e32bc89b71ac53576cf7789c1471a29a0a5339 SHA512 649e8bbf7f7f669d1bda13f1ab654428b69fa3e03a97eefb2ff1e996dbf62c66df72dddee9b8c139664ce5374ffbcdd8a10d1c4e3d0e6e65848ed5660b547d34
+DIST gzdoom-4.1.2.tar.gz 13045742 BLAKE2B 38c70eb82ba266e5b41bf62f28f4cee77ba17c0cc1e4186bf11be9021386511346c111874b695ef56a4ed3c93668bb64a71ba4169183646e49d0ab60a1c0793a SHA512 915029e676b17dd330aeee17fa8a9e07bb8e7a16e8ebce9fcdcd24e5b2f0cc48fd8f6914314029b332112ad4215a0f0d45d8e448e9025ac3c2a708a5e0bbd399
diff --git a/games-fps/gzdoom/gzdoom-4.1.2.ebuild b/games-fps/gzdoom/gzdoom-4.1.2.ebuild
new file mode 100644
index 000000000..cde070ad9
--- /dev/null
+++ b/games-fps/gzdoom/gzdoom-4.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BZIP2 DUMB-0.9.2 GPL-3 LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fluidsynth gtk openal openmp"
+
+DEPEND="
+ media-libs/libsdl2[opengl]
+ sys-libs/zlib
+ virtual/jpeg:0
+ gtk? ( <x11-libs/gtk+-4:= )"
+RDEPEND="
+ ${DEPEND}
+ fluidsynth? ( media-sound/fluidsynth )
+ openal? (
+ media-libs/libsndfile
+ media-libs/openal
+ media-sound/mpg123
+ )"
+
+S="${WORKDIR}/${PN}-g${PV}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${P}/docs"
+ -DNO_GTK="$(usex !gtk)"
+ -DNO_OPENAL="$(usex !openal)"
+ -DNO_OPENMP="$(usex !openmp)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newicon src/posix/zdoom.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}