aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Price <sprice623@aol.com>2022-11-01 20:01:35 -0400
committerSeth Price <sprice623@aol.com>2022-11-01 20:25:15 -0400
commitaf90724d627e3c43da5883f8aff4eb632ab3cc5b (patch)
tree71b9b8cef056fedaff33e1a1ae4c06e20db779d6 /games-misc
parentwww-servers/hinsightd: add 0.9.16, drop 0.9.15_p20220828 (diff)
downloadguru-af90724d627e3c43da5883f8aff4eb632ab3cc5b.tar.gz
guru-af90724d627e3c43da5883f8aff4eb632ab3cc5b.tar.bz2
guru-af90724d627e3c43da5883f8aff4eb632ab3cc5b.zip
games-misc/varlpenis: new package, add 3.0.2
Signed-off-by: Seth Price <sprice623@aol.com>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/varlpenis/varlpenis-3.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-misc/varlpenis/varlpenis-3.0.2.ebuild b/games-misc/varlpenis/varlpenis-3.0.2.ebuild
new file mode 100644
index 000000000..05ba2f782
--- /dev/null
+++ b/games-misc/varlpenis/varlpenis-3.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3
+
+DESCRIPTION="Generates ASCII-art penis of arbitrary length"
+HOMEPAGE="https://gitlab.com/ssterling/varlpenis"
+EGIT_REPO_URI="https://gitlab.com/ssterling/varlpenis.git https://github.com/ssterling/varlpenis.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="sys-devel/bmake"
+
+src_configure() {
+ local myconf
+ econf --ignore-invalid-arguments \
+ --use-color-ansi \
+ --use-posixtime \
+ --use-fullwidth \
+ ${myconf}
+}
+
+src_compile() {
+ bmake varlpenis
+}
+
+src_install() {
+ bmake DESTDIR="${D}" install
+ dodoc BUGS.md
+ dodoc CHANGELOG.md
+ dodoc README.md
+}