aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-06-10 16:16:39 +0200
committerMichael Mair-Keimberger <mmk@levelnine.at>2023-06-10 16:17:43 +0200
commitdbabf6041bcc8ee57f1784621d3a803ad8021ba0 (patch)
treeaecc1188d87b14bc77611d0af7ceeccc018d1101 /gui-apps/tofi
parentdev-vcs/got: add 0.89, drop 0.87 (diff)
downloadguru-dbabf6041bcc8ee57f1784621d3a803ad8021ba0.tar.gz
guru-dbabf6041bcc8ee57f1784621d3a803ad8021ba0.tar.bz2
guru-dbabf6041bcc8ee57f1784621d3a803ad8021ba0.zip
gui-apps/tofi: add 0.9.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at>
Diffstat (limited to 'gui-apps/tofi')
-rw-r--r--gui-apps/tofi/Manifest1
-rw-r--r--gui-apps/tofi/tofi-0.9.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/gui-apps/tofi/Manifest b/gui-apps/tofi/Manifest
index 0004959a6..0eb19e350 100644
--- a/gui-apps/tofi/Manifest
+++ b/gui-apps/tofi/Manifest
@@ -1 +1,2 @@
DIST tofi-0.8.1.tar.gz 352696 BLAKE2B c882f8915623188d7614f2bf06ed92fef358cf9acae2a1f1f2e34a812098bf3897a054428c5fbfa88231bc1153c02219611d7596e6e3dbc9148cd57359d79753 SHA512 61e7621ff7ee9dad44ebab9b49b2afc8eebe40f17eb3c8911443810b9e8efb108a96e63e2cbb459c584583ee3a7ef2a23308783ead0a184ebcb36eba31f52dce
+DIST tofi-0.9.1.tar.gz 430699 BLAKE2B cf5fa6b9cfcdbd8ad880ac94b0d465d1688f8877f9e3b02a7d6414c6f3e49d509633796b0fd74f517c2d67e956c5b19d557b626c7b5816d1499a1e17187d4bec SHA512 a14ab5ecf2c6e1ecb0ec3366c436140aa422995d464de513e81e454df0f303fc9661b534a3f40df4f14897629cd0cc299bb449482b676fbf254002731ac02231
diff --git a/gui-apps/tofi/tofi-0.9.1.ebuild b/gui-apps/tofi/tofi-0.9.1.ebuild
new file mode 100644
index 000000000..07aca8fdd
--- /dev/null
+++ b/gui-apps/tofi/tofi-0.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Fast and simple dmenu/rofi replacement for wlroots-based Wayland compositors"
+HOMEPAGE="https://github.com/philj56/tofi"
+SRC_URI="https://github.com/philj56/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/glib
+ dev-libs/wayland
+ media-libs/freetype:2
+ media-libs/harfbuzz
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/libxkbcommon
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ elibc_musl? ( sys-libs/fts-standalone )
+ "
+
+BDEPEND="
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+ "
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}