aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-09-10 13:43:14 +0200
committerMatthias Coppens <coppens.matthias.abc@gmail.com>2020-09-10 14:15:25 +0200
commitfb574fa21e6a0c2ff3cdca7313c6b7ca431507c2 (patch)
treee8c992f87848650457837b56c1db34d86eac612f /gui-apps/wdisplays
parentgames-util/legendary: Delete 0.20.0. (diff)
downloadguru-fb574fa21e6a0c2ff3cdca7313c6b7ca431507c2.tar.gz
guru-fb574fa21e6a0c2ff3cdca7313c6b7ca431507c2.tar.bz2
guru-fb574fa21e6a0c2ff3cdca7313c6b7ca431507c2.zip
gui-apps/wdisplays: Port patch to 9999
Port patch for version 1.0 to the live ebuild, I thought upstream would've pulled the PR already. Add GitHub link to HOMEPAGE. Fixed style to recommendations for proxy-maint ebuilds. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com>
Diffstat (limited to 'gui-apps/wdisplays')
-rw-r--r--gui-apps/wdisplays/wdisplays-1.0-r2.ebuild21
-rw-r--r--gui-apps/wdisplays/wdisplays-9999.ebuild21
2 files changed, 21 insertions, 21 deletions
diff --git a/gui-apps/wdisplays/wdisplays-1.0-r2.ebuild b/gui-apps/wdisplays/wdisplays-1.0-r2.ebuild
index f77ab59f4..3959f430e 100644
--- a/gui-apps/wdisplays/wdisplays-1.0-r2.ebuild
+++ b/gui-apps/wdisplays/wdisplays-1.0-r2.ebuild
@@ -3,19 +3,18 @@
EAPI=7
-EGIT_REPO_URI="https://github.com/cyclopsian/${PN}"
-case "${PV}" in
- "9999")
- inherit git-r3
- ;;
- *)
- SRC_URI="${EGIT_REPO_URI}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-esac
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cyclopsian/wdisplays.git"
+else
+ SRC_URI="https://github.com/cyclopsian/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
inherit meson xdg
DESCRIPTION="GUI display configurator for wlroots compositors"
-HOMEPAGE="https://cyclopsian.github.io/${PN}"
+HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
BDEPEND="
x11-libs/gtk+:3[wayland]
@@ -25,4 +24,4 @@ DEPEND="${BDEPEND}"
LICENSE="GPL-3+"
SLOT="0"
-PATCHES=("${FILESDIR}/${P}-pull20.patch")
+PATCHES=("${FILESDIR}/${PN}-1.0-pull20.patch")
diff --git a/gui-apps/wdisplays/wdisplays-9999.ebuild b/gui-apps/wdisplays/wdisplays-9999.ebuild
index e277e11ac..3959f430e 100644
--- a/gui-apps/wdisplays/wdisplays-9999.ebuild
+++ b/gui-apps/wdisplays/wdisplays-9999.ebuild
@@ -3,19 +3,18 @@
EAPI=7
-EGIT_REPO_URI="https://github.com/cyclopsian/${PN}"
-case "${PV}" in
- "9999")
- inherit git-r3
- ;;
- *)
- SRC_URI="${EGIT_REPO_URI}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-esac
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cyclopsian/wdisplays.git"
+else
+ SRC_URI="https://github.com/cyclopsian/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
inherit meson xdg
DESCRIPTION="GUI display configurator for wlroots compositors"
-HOMEPAGE="https://cyclopsian.github.io/${PN}"
+HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
BDEPEND="
x11-libs/gtk+:3[wayland]
@@ -24,3 +23,5 @@ DEPEND="${BDEPEND}"
LICENSE="GPL-3+"
SLOT="0"
+
+PATCHES=("${FILESDIR}/${PN}-1.0-pull20.patch")