aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-06-29 09:32:20 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-06-29 09:32:20 +0200
commit200dc0395f12dca02a1ec2227390bcc8145d73dd (patch)
tree76afcea90f69dac18ee757d07d90938c8f5a7911 /gui-apps
parentdev-libs/feedbackd-device-themes: add 0.4.0, drop 0.0.20220523 (diff)
downloadguru-200dc0395f12dca02a1ec2227390bcc8145d73dd.tar.gz
guru-200dc0395f12dca02a1ec2227390bcc8145d73dd.tar.bz2
guru-200dc0395f12dca02a1ec2227390bcc8145d73dd.zip
gui-apps/nwg-shell-config: add 0.5.39
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell-config/Manifest1
-rw-r--r--gui-apps/nwg-shell-config/nwg-shell-config-0.5.39.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell-config/Manifest b/gui-apps/nwg-shell-config/Manifest
index 9aea3679b..b108cd52b 100644
--- a/gui-apps/nwg-shell-config/Manifest
+++ b/gui-apps/nwg-shell-config/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-config-0.5.37.tar.gz 117615 BLAKE2B a6eff99bc54af754e71e118f7f5f78934e757e292b8c314672b91d18836f39bd85342a2015763a1d2ea5e2623dc85879f45e4dffc3c3f1108bf69199d2a5768b SHA512 27b0deb2769a136f120a0736c7bc1902deb55bbb33bad28b77f455a575e469d5229ef1eba69018106ef03829ac97488da85022fff423e018d9f2f03e98373f62
DIST nwg-shell-config-0.5.38.tar.gz 117607 BLAKE2B d233971aa62f42b815c72977ba923b6b61624821af0dbf0314ed57078e00e166e5866a8f0a4f87deda1c5dcac63b5694bf63b63529a64593a51f43d3c384abaf SHA512 848bf82306d68075db7f5d3b2bc13920e72b3f9fd027332c34b9a101fd9a9e92749ca9992e16713d929e6f5fb940b53abc27c02bdde8bf8615bfa8aa067c12b3
+DIST nwg-shell-config-0.5.39.tar.gz 117834 BLAKE2B f842a865155e4b18260a4c75f27446ee6fcbcf5dca1911f45dfd3f48019a668ae98c7038be9d23972b182044d5fe9b51922139d5c0f9e2eea6e077a30daad88a SHA512 8c5312231ddd85c4ef7ecbf03651acd6095552822c2da3b8cc8061f067ef8e2d1990130768e63598fa5399206944fffbbcd070c69e2cee3f2b7558fdd699ebbd
diff --git a/gui-apps/nwg-shell-config/nwg-shell-config-0.5.39.ebuild b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.39.ebuild
new file mode 100644
index 000000000..18bb5419f
--- /dev/null
+++ b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.39.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="nwg-shell configuration utility"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell-config"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell-config/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/nwg-shell
+ sci-geosciences/geopy
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-shell-config.desktop
+ doicon nwg-shell-config.svg
+ doicon nwg-shell-update.svg
+ doicon nwg-shell-translate.svg
+ doicon nwg-update-noupdate.svg
+ doicon nwg-update-available.svg
+ doicon nwg-update-checking.svg
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}