aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2022-09-11 12:01:03 -0400
committerEfe İzbudak <efe.izbudak@metu.edu.tr>2022-09-11 12:01:03 -0400
commit3cb22fe2d4fe26c08858c1656ce450e3c2dda10d (patch)
tree48875cfabf216b3388f8846bab00bb9e1df69676 /gui-apps
parentgui-apps/somebar: add 1.0.0 (diff)
downloadguru-3cb22fe2d4fe26c08858c1656ce450e3c2dda10d.tar.gz
guru-3cb22fe2d4fe26c08858c1656ce450e3c2dda10d.tar.bz2
guru-3cb22fe2d4fe26c08858c1656ce450e3c2dda10d.zip
gui-apps/someblocks: add 1.0.0
Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/someblocks/Manifest1
-rw-r--r--gui-apps/someblocks/someblocks-1.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/gui-apps/someblocks/Manifest b/gui-apps/someblocks/Manifest
new file mode 100644
index 000000000..156df4984
--- /dev/null
+++ b/gui-apps/someblocks/Manifest
@@ -0,0 +1 @@
+DIST someblocks-1.0.0.tar.gz 3967 BLAKE2B ab9c9ac97074c77dc17440fb3b628707ed51256a7d812b0ab8411a20029ebb48ae0092421f096e6c21f3e072c472e9863eec99ebbc6e809cb26de1638ef27520 SHA512 c7e0d77df2094d4bfe7ab616e848073d7bae06d9b3788574bc1b942469a618f4cb4cffebff7d5aabc014068d2350c08c3f83e41f9de0c0cc5ae1f3bf1ef10e8a
diff --git a/gui-apps/someblocks/someblocks-1.0.0.ebuild b/gui-apps/someblocks/someblocks-1.0.0.ebuild
new file mode 100644
index 000000000..47a592702
--- /dev/null
+++ b/gui-apps/someblocks/someblocks-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="Modular status bar for somebar written in c."
+HOMEPAGE="https://git.sr.ht/~raphi/someblocks"
+SRC_URI="https://git.sr.ht/~raphi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+
+ restore_config blocks.h
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+
+ einstalldocs
+
+ save_config blocks.h
+}