aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-15 17:49:27 +1200
committerTheo Anderson <telans@posteo.de>2021-04-15 19:09:10 +1200
commita2347a922275f14589d34fbdbf284917c58bb988 (patch)
tree614e8d2a1ffa0b4e13e1d61d10e439c0ba468f77 /gui-apps
parentgui-apps/wlr-randr: disable -Werror (diff)
downloadguru-a2347a922275f14589d34fbdbf284917c58bb988.tar.gz
guru-a2347a922275f14589d34fbdbf284917c58bb988.tar.bz2
guru-a2347a922275f14589d34fbdbf284917c58bb988.zip
gui-apps/wev: add dev-{libs,util}/wayland-{protocols,scanner} bdependency
* respect LDFLAGS * move PREFIX location fix to existing sed statement Closes: https://bugs.gentoo.org/781056 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wev/wev-1.0.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/gui-apps/wev/wev-1.0.0.ebuild b/gui-apps/wev/wev-1.0.0.ebuild
index 9e96f8688..bc72849eb 100644
--- a/gui-apps/wev/wev-1.0.0.ebuild
+++ b/gui-apps/wev/wev-1.0.0.ebuild
@@ -18,10 +18,16 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="
app-text/scdoc
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
virtual/pkgconfig
"
-src_install() {
- export PREFIX="${EPREFIX}/usr"
+src_prepare() {
default
+ # Respect LDFLAGS
+ # Install to /usr/ not /usr/local/
+ sed -e 's/$(LIBS)/$(LIBS) $(LDFLAGS)/' \
+ -e 's/local//' \
+ -i Makefile || die
}