aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@landless-city.net>2024-08-23 15:24:14 +0500
committerEric Joldasov <bratishkaerik@landless-city.net>2024-08-23 15:24:14 +0500
commit5f8a4e0b0720c964e18aa7791ae454f0dfb0eff9 (patch)
tree516bf4d3b8201429128de3e84e154a21de5d9bb5 /gui-wm
parentnet-vpn/candy: treeclean, this package has been moved to the main repository (diff)
downloadguru-5f8a4e0b0720c964e18aa7791ae454f0dfb0eff9.tar.gz
guru-5f8a4e0b0720c964e18aa7791ae454f0dfb0eff9.tar.bz2
guru-5f8a4e0b0720c964e18aa7791ae454f0dfb0eff9.zip
gui-wm/river: drop 0.3.5
Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/river/files/river-0.3.5-zig-0.12.0.patch27
-rw-r--r--gui-wm/river/river-0.3.5.ebuild154
2 files changed, 0 insertions, 181 deletions
diff --git a/gui-wm/river/files/river-0.3.5-zig-0.12.0.patch b/gui-wm/river/files/river-0.3.5-zig-0.12.0.patch
deleted file mode 100644
index d974d9b67..000000000
--- a/gui-wm/river/files/river-0.3.5-zig-0.12.0.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-zig-wayland-0.2.0
---- a/deps/p/1220687c8c47a48ba285d26a05600f8700d37fc637e223ced3aa8324f3650bf52242/src/scanner.zig
-+++ b/deps/p/1220687c8c47a48ba285d26a05600f8700d37fc637e223ced3aa8324f3650bf52242/src/scanner.zig
-@@ -528,7 +528,7 @@
- // These interfaces are special in that their version may never be increased.
- // That is, they are pinned to version 1 forever. They also may break the
- // normally required tree object creation hierarchy.
-- const version_locked_interfaces = std.StaticStringMap(void).initComptime(.{
-+ const version_locked_interfaces = std.ComptimeStringMap(void, .{
- .{"wl_display"},
- .{"wl_registry"},
- .{"wl_callback"},
-
-river-0.3.5
---- a/river/command.zig
-+++ b/river/command.zig
-@@ -36,9 +36,8 @@
- vertical,
- };
-
--const command_impls = std.StaticStringMap(
-+const command_impls = std.ComptimeStringMap(
- *const fn (*Seat, []const [:0]const u8, *?[]const u8) Error!void,
--).initComptime(
- .{
- // zig fmt: off
- .{ "attach-mode", @import("command/attach_mode.zig").defaultAttachMode },
diff --git a/gui-wm/river/river-0.3.5.ebuild b/gui-wm/river/river-0.3.5.ebuild
deleted file mode 100644
index 65e6d4373..000000000
--- a/gui-wm/river/river-0.3.5.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edo
-
-DESCRIPTION="A dynamic tiling Wayland compositor"
-HOMEPAGE="https://isaacfreund.com/software/river/"
-
-SRC_URI="
- https://codeberg.org/river/river/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://codeberg.org/ifreund/zig-pixman/archive/v0.2.0.tar.gz -> zig-pixman-0.2.0.tar.gz
- https://codeberg.org/ifreund/zig-wayland/archive/v0.2.0.tar.gz -> zig-wayland-0.2.0.tar.gz
- https://codeberg.org/ifreund/zig-wlroots/archive/v0.18.0.tar.gz -> zig-wlroots-0.18.0.tar.gz
- https://codeberg.org/ifreund/zig-xkbcommon/archive/v0.2.0.tar.gz -> zig-xkbcommon-0.2.0.tar.gz
-"
-S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}/${P}-zig-0.12.0.patch"
-)
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+X +llvm +man pie"
-
-EZIG_MIN="0.12"
-EZIG_MAX_EXCLUSIVE="0.13"
-
-DEPEND="
- dev-libs/libevdev
- dev-libs/wayland
- dev-libs/wayland-protocols
- gui-libs/wlroots:0.18=[X?]
- x11-libs/libxkbcommon:=[X?]
- x11-libs/pixman
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- || ( dev-lang/zig-bin:${EZIG_MIN} dev-lang/zig:${EZIG_MIN} )
- man? ( app-text/scdoc )
- virtual/pkgconfig
-"
-
-DOCS=( README.md )
-
-# https://github.com/ziglang/zig/issues/3382
-QA_FLAGS_IGNORED="usr/bin/*"
-
-# Many thanks to Florian Schmaus (Flowdalic)!
-# Adapted from https://github.com/gentoo/gentoo/pull/28986
-# Set the EZIG environment variable.
-zig-set_EZIG() {
- [[ -n ${EZIG} ]] && return
-
- local candidate selected selected_ver ver
-
- for candidate in "${BROOT}"/usr/bin/zig-*; do
- if [[ ! -L ${candidate} || ${candidate} != */zig?(-bin)-+([0-9.]) ]]; then
- continue
- fi
-
- ver=${candidate##*-}
-
- if [[ -n ${EZIG_EXACT_VER} ]]; then
- ver_test "${ver}" -ne "${EZIG_EXACT_VER}" && continue
-
- selected="${candidate}"
- selected_ver="${ver}"
- break
- fi
-
- if [[ -n ${EZIG_MIN} ]] \
- && ver_test "${ver}" -lt "${EZIG_MIN}"; then
- # Candidate does not satisfy EZIG_MIN condition.
- continue
- fi
-
- if [[ -n ${EZIG_MAX_EXCLUSIVE} ]] \
- && ver_test "${ver}" -ge "${EZIG_MAX_EXCLUSIVE}"; then
- # Candidate does not satisfy EZIG_MAX_EXCLUSIVE condition.
- continue
- fi
-
- if [[ -n ${selected_ver} ]] \
- && ver_test "${selected_ver}" -gt "${ver}"; then
- # Candidate is older than the currently selected candidate.
- continue
- fi
-
- selected="${candidate}"
- selected_ver="${ver}"
- done
-
- if [[ -z ${selected} ]]; then
- die "Could not find (suitable) zig installation in ${BROOT}/usr/bin"
- fi
-
- export EZIG="${selected}"
- export EZIG_VER="${selected_ver}"
-}
-
-# Invoke zig with the optionally provided arguments.
-ezig() {
- zig-set_EZIG
-
- edo "${EZIG}" "${@}"
-}
-
-src_unpack() {
- default
-
- # unpacking into ${S} to patch zig-wayland-0.2.0
- # without patches, it would be better using ${WORKDIR}/deps
- mkdir "${S}/deps" || die
- ezig fetch --global-cache-dir "${S}/deps" "${DISTDIR}/zig-pixman-0.2.0.tar.gz"
- ezig fetch --global-cache-dir "${S}/deps" "${DISTDIR}/zig-wayland-0.2.0.tar.gz"
- ezig fetch --global-cache-dir "${S}/deps" "${DISTDIR}/zig-wlroots-0.18.0.tar.gz"
- ezig fetch --global-cache-dir "${S}/deps" "${DISTDIR}/zig-xkbcommon-0.2.0.tar.gz"
-}
-
-src_configure() {
- export ZBS_ARGS=(
- --prefix usr/
- --system "${S}/deps/p"
- -Doptimize=ReleaseSafe
-
- -Dpie=$(usex pie true false)
- -Dno-llvm=$(usex llvm false true)
- -Dman-pages=$(usex man true false)
- -Dxwayland=$(usex X true false)
- )
-}
-
-src_compile() {
- ezig build "${ZBS_ARGS[@]}"
-}
-
-src_test() {
- ezig build test "${ZBS_ARGS[@]}"
-}
-
-src_install() {
- DESTDIR="${ED}" ezig build install "${ZBS_ARGS[@]}"
- einstalldocs
-
- insinto /usr/share/wayland-sessions
- doins contrib/river.desktop
-
- insinto /usr/share/${PN}
- doins -r example
-}