aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorRahul Sandhu <rahul@sandhuservices.dev>2023-04-16 09:48:16 +0100
committerRahul Sandhu <rahul@sandhuservices.dev>2023-04-16 09:48:16 +0100
commitef1844b107c366eaa8871a9eceb30a0296f3dc5e (patch)
tree1c33100f18860cb9ba228557e59104fb8e8f4636 /gui-wm
parentwww-apps/mycorrhiza: drop 1.13.0 (diff)
downloadguru-ef1844b107c366eaa8871a9eceb30a0296f3dc5e.tar.gz
guru-ef1844b107c366eaa8871a9eceb30a0296f3dc5e.tar.bz2
guru-ef1844b107c366eaa8871a9eceb30a0296f3dc5e.zip
gui-wm/swayfx: add 0.2
Signed-off-by: Rahul Sandhu <rahul@sandhuservices.dev>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/swayfx/Manifest1
-rw-r--r--gui-wm/swayfx/swayfx-0.2.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/gui-wm/swayfx/Manifest b/gui-wm/swayfx/Manifest
index e93c3f34d..46085d9f6 100644
--- a/gui-wm/swayfx/Manifest
+++ b/gui-wm/swayfx/Manifest
@@ -1 +1,2 @@
DIST 0.1.tar.gz 5514855 BLAKE2B 57be3ab5b66cb71a826ed6d7cd2dc70cc415f0f207420aa2b545f63ccfca5f7504d6a44554ff7e8000b35797540e52043902a5d6264cf1f8290a34e9876ef372 SHA512 9dd17d3628d59c2d2de521c26a3d49780fb95acd18b886dd7f515e210c0f876b51b37e83119ed082aa1fc28ae4631ae794cd81d20516ba77566639b2ba49e9fb
+DIST 0.2.tar.gz 5534158 BLAKE2B e01ac28ea24743d5fe937d953114c8316f3de27b7813f83cce0f6f76bf524f079357be810845791c4431db7e315f096411e6d7a0e2174673e4247d16e3e44bc1 SHA512 0884513a0851b19546f2cc647d8590c7d82494604028ed71b2e6fefbac7f3fff141be26e783ccc504b8da84bbed6c1e12a2194f0713c920e1cc34a6360ac318c
diff --git a/gui-wm/swayfx/swayfx-0.2.ebuild b/gui-wm/swayfx/swayfx-0.2.ebuild
new file mode 100644
index 000000000..ac081a87a
--- /dev/null
+++ b/gui-wm/swayfx/swayfx-0.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+MY_PV=${PV/_rc/-rc}
+SRC_URI="https://github.com/WillPower3309/swayfx/archive/refs/tags/${PV}.tar.gz"
+KEYWORDS="~amd64"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.6.0:0=
+ sys-auth/seatd:=
+ dev-libs/libpcre
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ tray? ( || (
+ sys-apps/systemd
+ sys-auth/elogind
+ sys-libs/basu
+ ) )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
+ X? ( x11-libs/libxcb:0= )
+"
+DEPEND+="
+ >=gui-libs/wlroots-0.15:=[X?]
+ <gui-libs/wlroots-0.16:=[X?]
+"
+RDEPEND="
+ x11-misc/xkeyboard-config
+ grimshot? (
+ app-misc/jq
+ gui-apps/grim
+ gui-apps/slurp
+ gui-apps/wl-clipboard
+ x11-libs/libnotify
+ )
+ !!gui-wm/sway
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+"
+BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+REQUIRED_USE="tray? ( swaybar )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use grimshot; then
+ doman contrib/grimshot.1
+ dobin contrib/grimshot
+ fi
+}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with swayfx:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}