aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-04-27 22:20:06 +0200
committerMarco Scardovi <marco@scardovi.com>2021-04-27 22:20:06 +0200
commit5b3e3ac052dd9fb24c85703b63548b00072449f8 (patch)
tree09e63bb9c9f554782739f0eadc16596c64bb9293 /media-gfx/grafx2
parentmedia-sound/nuclear-bin: use only one for...do...done for icons (diff)
downloadguru-5b3e3ac052dd9fb24c85703b63548b00072449f8.tar.gz
guru-5b3e3ac052dd9fb24c85703b63548b00072449f8.tar.bz2
guru-5b3e3ac052dd9fb24c85703b63548b00072449f8.zip
media-gfx/grafx2: fix build
Closes: https://bugs.gentoo.org/259896 ^ this bug is really old and grafx2 is in GURU now Closes: https://bugs.gentoo.org/784419 ^ sed is not required Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'media-gfx/grafx2')
-rw-r--r--media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild b/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild
index 32440b6e0..2e5d34f33 100644
--- a/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild
+++ b/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lua ttf"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
# Test phase fails: make: *** [Makefile:1146: ../bin/tests-sdl] Error 1
RESTRICT="test"
@@ -34,16 +35,15 @@ PATCHES=( "${FILESDIR}/${PN}-desktop-file.patch" )
src_prepare() {
pushd ../ && default && popd
- sed -i s/lua5\.1/lua/g Makefile || die "sed failed"
}
src_compile() {
use ttf || MYCNF="NOTTF=1"
use lua || MYCNF="${MYCNF} NOLUA=1"
- emake ${MYCNF} || die "emake failed"
+ emake ${MYCNF}
}
src_install() {
- emake ${MYCNF} DESTDIR="${D}" PREFIX="/usr" install || die "Install failed"
+ emake ${MYCNF} DESTDIR="${ED}" PREFIX="/usr" install
}