aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-06 22:51:45 +1300
committerTheo Anderson <telans@posteo.de>2020-12-06 22:51:45 +1300
commit8d9afabd1ceac2830056f626f976f611bdb7aa06 (patch)
tree41f1dc2c817bdd90131315e23126b282e50c3a42 /media-gfx/grafx2
parentdev-python/httpcore: new version (diff)
downloadguru-8d9afabd1ceac2830056f626f976f611bdb7aa06.tar.gz
guru-8d9afabd1ceac2830056f626f976f611bdb7aa06.tar.bz2
guru-8d9afabd1ceac2830056f626f976f611bdb7aa06.zip
media-gfx/grafx2: migrate to lua-single.eclass
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'media-gfx/grafx2')
-rw-r--r--media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild b/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild
new file mode 100644
index 000000000..eb9f7ac95
--- /dev/null
+++ b/media-gfx/grafx2/grafx2-2.7.2978-r100.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single xdg
+
+DESCRIPTION="A pixelart-oriented painting program"
+HOMEPAGE="http://www.pulkomandy.tk/projects/GrafX2"
+SRC_URI="http://www.pulkomandy.tk/projects/GrafX2/downloads/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua ttf"
+# Test phase fails: make: *** [Makefile:1146: ../bin/tests-sdl] Error 1
+RESTRICT="test"
+
+DEPEND="
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/freetype
+ media-libs/libpng
+ ttf? ( media-libs/sdl-ttf )
+ lua? ( ${LUA_DEPS} )
+"
+
+S="${WORKDIR}/${PN}/src/"
+
+PATCHES=( "${FILESDIR}/${PN}-desktop-file.patch" )
+
+src_prepare() {
+ pushd ../ && default && popd
+ sed -i s/lua5\.1/lua/g Makefile || die "sed failed"
+}
+
+src_compile() {
+ use ttf || MYCNF="NOTTF=1"
+ use lua || MYCNF="${MYCNF} NOLUA=1"
+
+ emake ${MYCNF} || die "emake failed"
+}
+
+src_install() {
+ emake ${MYCNF} DESTDIR="${D}" PREFIX="/usr" install || die "Install failed"
+}