aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2024-02-18 20:44:55 +0500
committerDenis Reva <denis7774@gmail.com>2024-02-18 20:45:12 +0500
commit1f60e50220d5005bd5a1ee76398aedff53c10570 (patch)
tree60fdbf9d7efa0a6cf0a364b07360e091faa68a4f /media-libs/amdvlk-bin
parentgames-util/xivlauncher: add 1.0.7 (diff)
downloadguru-1f60e50220d5005bd5a1ee76398aedff53c10570.tar.gz
guru-1f60e50220d5005bd5a1ee76398aedff53c10570.tar.bz2
guru-1f60e50220d5005bd5a1ee76398aedff53c10570.zip
media-libs/amdvlk-bin: added legacy-polaris branch
it contains the last driver version for pre-GFX10 gpus Improved package description Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'media-libs/amdvlk-bin')
-rw-r--r--media-libs/amdvlk-bin/Manifest2
-rw-r--r--media-libs/amdvlk-bin/amdvlk-bin-2023.3.3.ebuild120
-rw-r--r--media-libs/amdvlk-bin/amdvlk-bin-2024.1.1.ebuild7
3 files changed, 129 insertions, 0 deletions
diff --git a/media-libs/amdvlk-bin/Manifest b/media-libs/amdvlk-bin/Manifest
index 13d0d1647..331888a2b 100644
--- a/media-libs/amdvlk-bin/Manifest
+++ b/media-libs/amdvlk-bin/Manifest
@@ -1,2 +1,4 @@
+DIST amdvlk-bin-2023.3.3-amd64.rpm 16954920 BLAKE2B 8b8d2e353a2055a823c5a7932c55a5e113036388a68c2f61a665de0209e82dd219b21e6f4a79f2ad6141381601e408b0007068140fcc2692bf5904ac289ab597 SHA512 827bcf885f207557b452360491187b9909279a601dff9c635561b4aa5f2c8aae9d940e880a98c7fb1482efd7fec068e8f3667729930ecd20dfa7c06be15193c9
+DIST amdvlk-bin-2023.3.3-i386.deb 25352166 BLAKE2B f4e3af91c2f4e7be6c447c2553ac3deed106be86ce3bd3204ac2e6734ca09dba4c59da8ffd49b52f85dfcbe5eaba09cfa2519578ececfb6f7b21ee4a3d67430d SHA512 3668d701292b7283409ec2209f52b0b01cd7821754969efc4c91c74b2b075ee612f41fafd471dd92da1b204644c76bb92fd60c4c916588b7ee8961257523ba50
DIST amdvlk-bin-2024.1.1-amd64.rpm 18242384 BLAKE2B f26155287dfd7c968581b5eba3a4ad4ac9e1c0d4740a9aa57e120c8a21a1638cf0f02bcf3fd51fb2b6150031b7d81a2c755095807f8afbec5727be4dd661bcaf SHA512 f75b175377a9c252d564db5d99aae47d833d6ddc2c0b7c9292113e96e0635d059deae82ef54e9a88025c28b8b2271113ab468c72a0aa16c4908857b970f3634e
DIST amdvlk-bin-2024.1.1-i386.deb 25981812 BLAKE2B c8cb424798b6d2f64f0d4c68930c4fbe7ac02039373d33aa6cc0c2912b71df7a7adff64e3f60be52f3bd4bcec0c91ee5f3a0edfaa88dc2f09390c245e94f0170 SHA512 6c3f5aea6e734fa3550c7f4103108dd3efca2ce0ddb1e0410b46ef3d4171deb66cf10b2e38935bf965d729daa221fd6af119582ef7b15e779df80d84122b9587
diff --git a/media-libs/amdvlk-bin/amdvlk-bin-2023.3.3.ebuild b/media-libs/amdvlk-bin/amdvlk-bin-2023.3.3.ebuild
new file mode 100644
index 000000000..43d652934
--- /dev/null
+++ b/media-libs/amdvlk-bin/amdvlk-bin-2023.3.3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit rpm unpacker multilib-build
+
+DESCRIPTION="AMD Open Source Driver for Vulkan: official binary version"
+HOMEPAGE="https://github.com/GPUOpen-Drivers/AMDVLK"
+MY_PV="${PV/'.'/'.Q'}"
+FETCH_URI="https://github.com/GPUOpen-Drivers/AMDVLK/releases/download"
+SRC_URI="${FETCH_URI}/v-${MY_PV}/amdvlk-${MY_PV}.x86_64.rpm -> ${P}-amd64.rpm
+${FETCH_URI}/v-${MY_PV}/amdvlk_${MY_PV}_i386.deb -> ${P}-i386.deb"
+RESTRICT="test"
+REQUIRED_USE="abi_x86_64"
+
+LICENSE="MIT"
+SLOT="legacy-polaris"
+KEYWORDS="-* ~amd64" # The hardware is not supported x86 anymore
+
+RDEPEND="
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ app-arch/zstd[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxshmfence[${MULTILIB_USEDEP}]
+ >=media-libs/vulkan-loader-1.3.224[${MULTILIB_USEDEP}]
+ !media-libs/amdvlk
+ !media-libs/amdvlk-bin:0
+ "
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="sys-apps/sed"
+QA_PREBUILT="
+ usr/lib/*
+ usr/lib64/*
+"
+# TODO: Found a correct way to disable QA_SONAME for /usr/lib/amdvlk32.so
+# I don't know why the current value is not working
+QA_SONAME="usr/lib/*"
+
+S=${WORKDIR}
+
+pkg_pretend(){
+ einfo "This is last version which supports AMD's legacy graphics cards such as:"
+ einfo "Radeon™ RX Vega Series"
+ einfo "Radeon™ RX 400/500 Series"
+ einfo "Radeon™ Pro WX 9100, x200 Series"
+ einfo "Radeon™ Pro W5700/W5500 Series"
+ einfo "Use it at your own risk"
+ einfo "Check Gentoo Wiki for further information"
+ einfo "https://wiki.gentoo.org/wiki/AMDVLK"
+ if use abi_x86_32; then
+ ewarn "32-bit amdvlk binary is untested"
+ ewarn "Work in progress, use it at your risk"
+ fi
+}
+
+src_unpack(){
+ elog "Unpacking abi_x86_64..."
+ mkdir -p "${S}"/amd64
+ cd "${S}"/amd64 || die
+ rpm_unpack ${P}-amd64.rpm
+ if use abi_x86_32; then
+ elog "Unpacking abi_x86_32..."
+ mkdir -p "${S}"/i386 || die
+ cd "${S}"/i386 || die
+ unpacker ${P}-i386.deb
+ fi
+}
+
+src_prepare() {
+ default
+ if use abi_x86_32; then
+ elog "Changing layout of abi_x86_32 from debian/ubuntu to Gentoo/RHEL-alike"
+ mv "${S}/i386/usr/lib/i386-linux-gnu/amdvlk32.so" "${S}/i386/usr/lib/" || die
+ rm -d "${S}/i386/usr/lib/i386-linux-gnu/" || die
+ rm -r "${S}/i386/usr/share/" || die
+ fi
+ mv "${S}/amd64/usr/share/doc/amdvlk/LICENSE.txt" "${S}" || die
+ rm -r "${S}/amd64/usr/share/" || die
+}
+
+src_configure(){
+ if use abi_x86_32; then
+ elog "Changing configuration of abi_x86_32 from debian/ubuntu to Gentoo/RHEL-alike"
+ sed -i 's/\/usr\/lib\/i386-linux-gnu\/amdvlk32.so/\/usr\/lib\/amdvlk32.so/g' \
+ "${S}/i386/etc/vulkan/icd.d/amd_icd32.json" || die
+ sed -i 's/\/usr\/lib\/i386-linux-gnu\/amdvlk32.so/\/usr\/lib\/amdvlk32.so/g' \
+ "${S}/i386/etc/vulkan/implicit_layer.d/amd_icd32.json" || die
+ fi
+}
+src_compile(){
+ elog "Nothing to compile..."
+}
+
+src_install(){
+ if use abi_x86_32; then
+ cp -a "${S}/i386"/* "${D}" || die
+ fi
+ cp -a "${S}/amd64"/* "${D}" || die
+ dodoc LICENSE.txt
+}
+
+pkg_postinst(){
+ ewarn "If you are using Xorg:"
+ ewarn "Make sure the following line is NOT included in the any Xorg configuration section:"
+ ewarn "| Driver \"modesetting\""
+ ewarn "and make sure you use DRI3 mode for Xorg"
+ ewarn "If you are using Wayland, it should be fine"
+ elog "More information about the configuration can be found here:"
+ elog "https://github.com/GPUOpen-Drivers/AMDVLK"
+ elog "See also https://wiki.gentoo.org/wiki/AMDVLK (but it might be outdated)"
+ elog "You can use AMD_VULKAN_ICD variable to switch to the required driver."
+ elog "AMD_VULKAN_ICD=RADV application - for using radv."
+ elog "AMD_VULKAN_ICD=AMDVLK application - for using amdvlk."
+}
diff --git a/media-libs/amdvlk-bin/amdvlk-bin-2024.1.1.ebuild b/media-libs/amdvlk-bin/amdvlk-bin-2024.1.1.ebuild
index f730b207d..dfba1714d 100644
--- a/media-libs/amdvlk-bin/amdvlk-bin-2024.1.1.ebuild
+++ b/media-libs/amdvlk-bin/amdvlk-bin-2024.1.1.ebuild
@@ -27,6 +27,8 @@ RDEPEND="
x11-libs/libxcb[${MULTILIB_USEDEP}]
x11-libs/libxshmfence[${MULTILIB_USEDEP}]
>=media-libs/vulkan-loader-1.3.224[${MULTILIB_USEDEP}]
+ !media-libs/amdvlk
+ !media-libs/amdvlk-bin:legacy-polaris
"
DEPEND="
${RDEPEND}
@@ -43,6 +45,11 @@ QA_SONAME="usr/lib/*"
S=${WORKDIR}
pkg_pretend(){
+ ewarn "Mainline AMDVLK drops support for pre-NAVI graphics cards"
+ ewarn "Such as Radeon™ RX 400/500 Series"
+ ewarn "or Radeon™ RX Vega Series"
+ einfo "Check Gentoo Wiki for further information"
+ einfo "https://wiki.gentoo.org/wiki/AMDVLK"
if use abi_x86_32; then
ewarn "32-bit amdvlk binary is untested"
ewarn "Work in progress"