aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Fröhning <misanthropos@gmx.net>2024-04-04 09:44:53 +0200
committerRichard Fröhning <misanthropos@gmx.net>2024-04-04 09:48:49 +0200
commit08d06932dff9e027543cb6171efc6d1a860cc517 (patch)
tree7554bacc09e393bd49c3040811086e03ea3344f4 /media-sound
parentnet-irc/halloy: Ensure build fails if sed command fails (diff)
downloadguru-08d06932dff9e027543cb6171efc6d1a860cc517.tar.gz
guru-08d06932dff9e027543cb6171efc6d1a860cc517.tar.bz2
guru-08d06932dff9e027543cb6171efc6d1a860cc517.zip
media-sound/rsgain: add v3.5
Really Simple GAIN scans audio files recursivley for a given directory while calculating and tagging replay gain values accoringly. rsgain is based on loudgain. Signed-off-by: Richard Fröhning <misanthropos@gmx.net>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rsgain/Manifest1
-rw-r--r--media-sound/rsgain/metadata.xml15
-rw-r--r--media-sound/rsgain/rsgain-3.5.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/rsgain/Manifest b/media-sound/rsgain/Manifest
new file mode 100644
index 000000000..58ada04aa
--- /dev/null
+++ b/media-sound/rsgain/Manifest
@@ -0,0 +1 @@
+DIST rsgain-3.5-source.tar.xz 50660 BLAKE2B 18a7d5b1892f1df8fbdfaddf289564540eb706638bc36d5822f79ca672ef2b0cbcc7a246567a4930aa6fa9da44598e69eed01ed3d62ebde98a26c375cae8d057 SHA512 aa870ffcbb333c6b604ee45593e4976c4aca39af7a88f0517b470a3d29c7bc74aeb7bcc8a68f5604aee74114f9751c64d4b5e55711e1340ed2f682ae641d29af
diff --git a/media-sound/rsgain/metadata.xml b/media-sound/rsgain/metadata.xml
new file mode 100644
index 000000000..50c365d25
--- /dev/null
+++ b/media-sound/rsgain/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>misanthropos@gmx.net</email>
+ <name>Richard Fröhning</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">complexlogic/rsgain</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/rsgain/rsgain-3.5.ebuild b/media-sound/rsgain/rsgain-3.5.ebuild
new file mode 100644
index 000000000..c7416aa2a
--- /dev/null
+++ b/media-sound/rsgain/rsgain-3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Really Simple replay Gain calculator for tagging audio files"
+HOMEPAGE="https://github.com/complexlogic/rsgain"
+SRC_URI="https://github.com/complexlogic/rsgain/releases/download/v${PV}/${P}-source.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libfmt
+ media-libs/libebur128
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/taglib
+ media-video/ffmpeg
+"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}