aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-07-30 12:42:53 +0200
committerJonas Frei <freijon@pm.me>2023-07-30 12:43:23 +0200
commit99c1f1506eec7e2c5dbc8b6512d94fa58415fbc5 (patch)
tree6b68b12e9b01cb258dcd3d8972e8a175e5dc6412 /media-sound
parentgui-wm/cage: drop 0.1.3, drop 0.1.4, add 0.1.5 (diff)
downloadguru-99c1f1506eec7e2c5dbc8b6512d94fa58415fbc5.tar.gz
guru-99c1f1506eec7e2c5dbc8b6512d94fa58415fbc5.tar.bz2
guru-99c1f1506eec7e2c5dbc8b6512d94fa58415fbc5.zip
media-sound/dzr: add 230730
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dzr/Manifest1
-rw-r--r--media-sound/dzr/dzr-230730.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/dzr/Manifest b/media-sound/dzr/Manifest
index f856b7cce..b5d8d3d19 100644
--- a/media-sound/dzr/Manifest
+++ b/media-sound/dzr/Manifest
@@ -1 +1,2 @@
DIST dzr-230513.tar.gz 8678 BLAKE2B 78487e9601cf8516a7913a2a640fd3ea8aba70f1f0e43b7189d03e25920daa9270428ce3189bee39529172325bf0fe08186c7ffcfcf811c5ab0adae975cc2e23 SHA512 fe2676b1d47313427db0f38cdedfd69cb1403a4e2df49e08f6ac4984cd4809425af7746a5008fa425ab9835a15a1cced6e197b96118b5d851d92ac9accd36b6d
+DIST dzr-230730.tar.gz 8848 BLAKE2B 7551fb961167031f926de6559fca7eb48dae69c40ac1e896cdcdeadd03c4cf3c19ca514a65f77d00a7cfbc52972489baf557f927358fe61947831e2026877264 SHA512 7f011838da380abc736b861abf2d665ba29b1d0f97f9a234d6a3a5b28638494ac7f0a8544af963ce463c5b37f171e1927d45fc453d2bb323599dcd71c4bb3744
diff --git a/media-sound/dzr/dzr-230730.ebuild b/media-sound/dzr/dzr-230730.ebuild
new file mode 100644
index 000000000..94371499e
--- /dev/null
+++ b/media-sound/dzr/dzr-230730.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="DZR: the command line deezer.com player"
+HOMEPAGE="https://github.com/yne/dzr"
+SRC_URI="https://github.com/yne/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-misc/jq[oniguruma]
+ dev-libs/openssl
+ dev-util/dialog
+ media-video/mpv
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ exeinto /usr/bin
+ doexe dzr
+ doexe dzr-dec
+ doexe dzr-id3
+ doexe dzr-srt
+ doexe dzr-url
+ default
+}
+
+pkg_postinst() {
+ einfo "WARNING: For legal reasons this project"
+ einfo "does not contain the track decryption key."
+ einfo "Please read the following guide first:"
+ einfo "https://github.com/yne/dzr/wiki#find-the-dzr_cbc-key"
+}