aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-05-04 19:17:40 +0200
committerJonas Frei <freijon@pm.me>2023-05-04 19:18:08 +0200
commited27f1f804c5b4fe6e7c196ba00ad90f7dd78b39 (patch)
tree9405d89d4428211d35ba0dac3f7ce0b839ef71a7 /media-sound
parentsys-fs/python-btrfs: enable py3.11 (diff)
downloadguru-ed27f1f804c5b4fe6e7c196ba00ad90f7dd78b39.tar.gz
guru-ed27f1f804c5b4fe6e7c196ba00ad90f7dd78b39.tar.bz2
guru-ed27f1f804c5b4fe6e7c196ba00ad90f7dd78b39.zip
media-sound/dzr: add 230504
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dzr/Manifest1
-rw-r--r--media-sound/dzr/dzr-230504.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/dzr/Manifest b/media-sound/dzr/Manifest
index e5b9729b7..dd38bdf83 100644
--- a/media-sound/dzr/Manifest
+++ b/media-sound/dzr/Manifest
@@ -1 +1,2 @@
DIST dzr-230501.tar.gz 8639 BLAKE2B e3ceef26f4e3f7b8c036f24c712f6ad635e0e9ae7102803ea9bb3b164ab405f0d3c80451ef43e14b62d475d494758210afba944a62e260ca02e186905b831711 SHA512 be38c1e2966f67eb351453d84571689dd787fdfd4057562a0cea9e5f53cf271bfa3943efbe7f4ec43437b4d274212dea8d37634cd28528c8dce5c6bec6b93723
+DIST dzr-230504.tar.gz 8643 BLAKE2B ccea6708e50dea624351a90bc2b8a7f117834ebdc6ee177c6da2dcd63fcb22186d50a4ccad6efd111ee763d6e917b557d8bb823481f7f76d98600dab3bc0fbe0 SHA512 93a3d4559e241c9cecb4676e53d75a222d50ba87e5bcd54bf7a13777816e4ce7d8c284c276eee19fec59996d20b03a4a8cd317bd867193a6aab4b279fb5aae63
diff --git a/media-sound/dzr/dzr-230504.ebuild b/media-sound/dzr/dzr-230504.ebuild
new file mode 100644
index 000000000..94371499e
--- /dev/null
+++ b/media-sound/dzr/dzr-230504.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="DZR: the command line deezer.com player"
+HOMEPAGE="https://github.com/yne/dzr"
+SRC_URI="https://github.com/yne/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-misc/jq[oniguruma]
+ dev-libs/openssl
+ dev-util/dialog
+ media-video/mpv
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ exeinto /usr/bin
+ doexe dzr
+ doexe dzr-dec
+ doexe dzr-id3
+ doexe dzr-srt
+ doexe dzr-url
+ default
+}
+
+pkg_postinst() {
+ einfo "WARNING: For legal reasons this project"
+ einfo "does not contain the track decryption key."
+ einfo "Please read the following guide first:"
+ einfo "https://github.com/yne/dzr/wiki#find-the-dzr_cbc-key"
+}