aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2022-07-10 14:44:08 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2022-07-10 14:44:08 +0400
commitfde97c7e5637424e146fba67974862ca33ad6f87 (patch)
tree5855dfbb97f1b4ee83923ed1c165ab1ba0722604 /media-sound
parentmedia-sound/nulloy: move general block outside of IF (diff)
downloadguru-fde97c7e5637424e146fba67974862ca33ad6f87.tar.gz
guru-fde97c7e5637424e146fba67974862ca33ad6f87.tar.bz2
guru-fde97c7e5637424e146fba67974862ca33ad6f87.zip
media-sound/nulloy: do not strip
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/nulloy/files/add-nostrip.patch9
-rw-r--r--media-sound/nulloy/nulloy-0.9.3.ebuild6
-rw-r--r--media-sound/nulloy/nulloy-9999.ebuild12
3 files changed, 12 insertions, 15 deletions
diff --git a/media-sound/nulloy/files/add-nostrip.patch b/media-sound/nulloy/files/add-nostrip.patch
deleted file mode 100644
index 39b78be70..000000000
--- a/media-sound/nulloy/files/add-nostrip.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/nulloy.pro
-+++ b/nulloy.pro
-@@ -1,5 +1,5 @@
- TEMPLATE = subdirs
--CONFIG += ordered
-+CONFIG += ordered nostrip
-
- isEmpty(N_CONFIG_SUCCESS) {
- unix:error("Please run './configure'")
diff --git a/media-sound/nulloy/nulloy-0.9.3.ebuild b/media-sound/nulloy/nulloy-0.9.3.ebuild
index bfce51ba0..e7e7056ae 100644
--- a/media-sound/nulloy/nulloy-0.9.3.ebuild
+++ b/media-sound/nulloy/nulloy-0.9.3.ebuild
@@ -58,6 +58,12 @@ src_configure() {
)
QMAKE=/usr/bin/qmake5 LRELEASE=/usr/lib64/qt5/bin/lrelease ./configure "${myconfargs[@]}" || die
+
+ # Because stripping should not be done by the build tools,
+ # because Portage does it when the install phase is run to be able
+ # to support the `splitdebug` and `installsources` FEATURES.
+ # See related issue https://bugs.gentoo.org/856292
+ echo "CONFIG += nostrip" >> $WORKDIR/$P/.qmake.cache
}
src_install() {
diff --git a/media-sound/nulloy/nulloy-9999.ebuild b/media-sound/nulloy/nulloy-9999.ebuild
index 7408f0030..8932c9364 100644
--- a/media-sound/nulloy/nulloy-9999.ebuild
+++ b/media-sound/nulloy/nulloy-9999.ebuild
@@ -45,12 +45,6 @@ src_unpack() {
src_prepare() {
default
- # Because stripping should not be done by the build tools,
- # because Portage does it when the install phase is run to be able
- # to support the `splitdebug` and `installsources` FEATURES.
- # See related issue https://bugs.gentoo.org/856292
- eapply $FILESDIR/add-nostrip.patch
-
if use skins ; then
eapply $FILESDIR/add-dark-theme.patch
cp -r $WORKDIR/night src/skins
@@ -71,6 +65,12 @@ src_configure() {
)
QMAKE=/usr/bin/qmake5 LRELEASE=/usr/lib64/qt5/bin/lrelease ./configure "${myconfargs[@]}" || die
+
+ # Because stripping should not be done by the build tools,
+ # because Portage does it when the install phase is run to be able
+ # to support the `splitdebug` and `installsources` FEATURES.
+ # See related issue https://bugs.gentoo.org/856292
+ echo "CONFIG += nostrip" >> $WORKDIR/$P/.qmake.cache
}
src_install() {