aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2023-09-22 09:46:11 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2023-09-22 09:46:11 +0200
commit7d80f54d2bdce2a006689335cf0edcc635629afc (patch)
tree3d8553c510c66b68fb918346a6a5db21d7f32ac1 /net-dialup
parentmedia-sound/dzr: drop 230912 (diff)
downloadguru-7d80f54d2bdce2a006689335cf0edcc635629afc.tar.gz
guru-7d80f54d2bdce2a006689335cf0edcc635629afc.tar.bz2
guru-7d80f54d2bdce2a006689335cf0edcc635629afc.zip
net-dialup/tio: add 2.7
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-2.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index aee36b65f..d8101c1b1 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-2.6.tar.xz 3429792 BLAKE2B d0aa262e663eea416c696511e2441ce4b59ff3449ff4a743ffa21653442305c7417e941640239f21717c57d5a2a63d08959cfd3d3f7119f9263a8c0bfc75bf1c SHA512 6ff7a0492ea2bffd6f4cfb2745e0a3be2825e2a5c78fb0a35887cbe461472ffe0707c91a7eabd8744f7b52a8ee059b2e9a51e81fa426be2ffab6cf546e5ddd23
+DIST tio-2.7.tar.xz 3432332 BLAKE2B ae6fe436ccc45c22e5cf424cd71fe79c9e467ee13d2c271d122d43afaa1cef3886cd30596bc0acb9ce3fdb57376f23dace3381a3b84b798f3986bbe8aef6a3a5 SHA512 e5e7d32c59693cc95c1af8f909f869868dc361e5add9d184df188d73fb1dd01b5a431aa150a43861e477ebca8d4dc31ae6d7a25f54e63c48c6f13fbb5c8bbb7b
diff --git a/net-dialup/tio/tio-2.7.ebuild b/net-dialup/tio/tio-2.7.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-2.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}