aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-07-08 18:28:03 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-07-08 18:29:09 +0200
commite31c5ec23306f5c720dff4c79d870239764e52bb (patch)
tree62d2c5b8878664104eb2e7ae404f48fd8ce51f45 /net-dialup
parentgames-util/legendary: add 0.20.27 (diff)
downloadguru-e31c5ec23306f5c720dff4c79d870239764e52bb.tar.gz
guru-e31c5ec23306f5c720dff4c79d870239764e52bb.tar.bz2
guru-e31c5ec23306f5c720dff4c79d870239764e52bb.zip
net-dialup/tio: add 1.42
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-1.42.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index c01042dbe..6540afa48 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-1.40.tar.xz 3069480 BLAKE2B 5d5ef6478fa80eecf96599c6c55a77fd8e2b9259fd44fab105ee5f6c6b5494d5656599374f7ffe43741c7925a2bedac4c593ad8695abd6ba9ceca559f9272d4c SHA512 41f92d757fea3099e9974c64736aa75f69961ba5baf7b01cdb281656bcbf6490afe3748ce49c080624b5f4d3493a8398b8d702be0423f2bcbd0f0484bf76fdf6
+DIST tio-1.42.tar.xz 3070588 BLAKE2B 24ab0f72d6927a5c56b7fc73ab763aef208749bd2c5b6d91cfd346c577a7128e5f6d66596b75dff06b3189a9dfacdb53f66f1c7975b9ce6b5b116520e0cf8479 SHA512 83e9681e33962c2aeb3b4a4e80f8ee190ec087451bb570fa3655b12f2d4f2740a281ac177659627f6c5f694f1f78003881d3ec2388f9702e4da3f5999e70976d
diff --git a/net-dialup/tio/tio-1.42.ebuild b/net-dialup/tio/tio-1.42.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-1.42.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}