aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-23 23:10:21 +1300
committerTheo Anderson <telans@posteo.de>2020-12-23 23:10:21 +1300
commit1a13dc120923ba7391043ecda0c2af348bbcb8c7 (patch)
treeced4a77a052677f09071f7f1fb55de22d6031860 /net-misc/openbgpd
parentdev-libs/octetos-db-maria: depend dev-db/mariadb (diff)
downloadguru-1a13dc120923ba7391043ecda0c2af348bbcb8c7.tar.gz
guru-1a13dc120923ba7391043ecda0c2af348bbcb8c7.tar.bz2
guru-1a13dc120923ba7391043ecda0c2af348bbcb8c7.zip
net-misc/openbgpd: append-cflags -fcommon
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'net-misc/openbgpd')
-rw-r--r--net-misc/openbgpd/openbgpd-6.8_p0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-misc/openbgpd/openbgpd-6.8_p0.ebuild b/net-misc/openbgpd/openbgpd-6.8_p0.ebuild
index ccd7a6baf..fc029efd1 100644
--- a/net-misc/openbgpd/openbgpd-6.8_p0.ebuild
+++ b/net-misc/openbgpd/openbgpd-6.8_p0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit flag-o-matic systemd
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
@@ -38,6 +38,11 @@ src_install() {
systemd_newunit "${FILESDIR}/${PN}.service" bgpd.service
}
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
pkg_postinst() {
if [ -z "${REPLACING_VERSIONS}" ]; then
ewarn ""