aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2021-01-05 15:30:17 +0800
committerHuang Rui <vowstar@gmail.com>2021-01-05 15:30:17 +0800
commit3055a6a15b770042fafd62327d6b8762294385a7 (patch)
tree936fea16593ae742a75ee2efb19c2017688857b8 /sci-electronics
parentapp-office/beancount: bump python compat up to 3.9 (diff)
downloadguru-3055a6a15b770042fafd62327d6b8762294385a7.tar.gz
guru-3055a6a15b770042fafd62327d6b8762294385a7.tar.bz2
guru-3055a6a15b770042fafd62327d6b8762294385a7.zip
sci-electronics/bsc: new package for live build
Bluespec High Level Hardware Design Language, bsv compiler Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/bsc/bsc-9999.ebuild42
-rw-r--r--sci-electronics/bsc/metadata.xml17
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-electronics/bsc/bsc-9999.ebuild b/sci-electronics/bsc/bsc-9999.ebuild
new file mode 100644
index 000000000..4224ee7f9
--- /dev/null
+++ b/sci-electronics/bsc/bsc-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Bluespec High Level Hardware Design Language"
+HOMEPAGE="https://github.com/B-Lang-org/bsc"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/B-Lang-org/${PN}.git"
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="BSD GPL-3+ MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-haskell/old-time:0=
+ dev-haskell/regex-compat:0=
+ dev-haskell/split:0=
+ dev-haskell/syb:0=
+ dev-lang/tcl
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ dev-haskell/cabal:0=
+ dev-lang/ghc:0=
+ dev-util/gperf
+"
+
+src_install() {
+ emake PREFIX="${D}" install
+}
diff --git a/sci-electronics/bsc/metadata.xml b/sci-electronics/bsc/metadata.xml
new file mode 100644
index 000000000..826f1f530
--- /dev/null
+++ b/sci-electronics/bsc/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">B-Lang-org/bsc</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ This is a compiler, simulator, and associated tools for Bluespec High Level
+ Hardware Design Language (HL-HDL), supporting the two optional syntaxes,
+ BSV and BH. Language specifications and tutorials are available in the
+ BSVlang repository.
+ </longdescription>
+</pkgmetadata>