aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2021-01-24 19:01:13 +0800
committerHuang Rui <vowstar@gmail.com>2021-01-24 19:01:13 +0800
commit54f750c3d078f9779c4fcaebe030be8f0fd305f9 (patch)
tree542c107014a4d18ed57c220dad69e8416aa887e8 /sci-electronics
parentsci-electronics/bsc: fix test depend package (diff)
downloadguru-54f750c3d078f9779c4fcaebe030be8f0fd305f9.tar.gz
guru-54f750c3d078f9779c4fcaebe030be8f0fd305f9.tar.bz2
guru-54f750c3d078f9779c4fcaebe030be8f0fd305f9.zip
sci-electronics/bsc: bump to 0_pre20210124
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/bsc/bsc-0_pre20210124.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-electronics/bsc/bsc-0_pre20210124.ebuild b/sci-electronics/bsc/bsc-0_pre20210124.ebuild
new file mode 100644
index 000000000..5769c1fbc
--- /dev/null
+++ b/sci-electronics/bsc/bsc-0_pre20210124.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bluespec high level hardware design language compiler"
+HOMEPAGE="https://github.com/B-Lang-org/bsc"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/B-Lang-org/${PN}.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="69dee0667e51108832b685511e9aa631cca1e83a"
+ # Using SRC_URI here will failed because this repo uses git submodules.
+ # SRC_URI="https://github.com/B-Lang-org/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ # S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+ # Waiting for https://github.com/B-Lang-org/bsc/issues/85
+ EGIT_REPO_URI="https://github.com/B-Lang-org/${PN}.git"
+ # This inherit git-r3 will removed after upstream finished.
+ inherit git-r3
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD GPL-3+ MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-haskell/old-time:0=
+ dev-haskell/regex-compat:0=
+ dev-haskell/split:0=
+ dev-haskell/syb:0=
+ dev-lang/tcl
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-util/dejagnu
+ sci-electronics/systemc
+ sys-process/time
+ )
+"
+
+BDEPEND="
+ dev-haskell/cabal:0=
+ dev-lang/ghc:0=
+ dev-util/gperf
+ sys-devel/autoconf
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_pre20210106-fix-libdir.patch
+ "${FILESDIR}"/${PN}-0_pre20210106-fix-wrapper.patch
+)
+
+DOCS=( "README.md" "COPYING" )
+
+# We don't want to run it because it will do install by default.
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX="${ED%/}"/usr LIBDIR="${ED%/}"/usr/$(get_libdir) install
+ emake -C src/comp PREFIX="${ED%/}"/usr LIBDIR="${ED%/}"/usr/$(get_libdir) install-extra
+ einstalldocs
+}