aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-07-19 21:33:15 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-07-19 21:33:15 +0400
commit79341e9f046f373509b9ab9d14ef711797d5bfa5 (patch)
tree0e7a7f713f4587b70c4d7a4eb3ec0f0505a00644 /sci-mathematics/frama-c-constant-folding
parentdev-util/juliaup: add 1.16.10, drop 1.14.9 (diff)
downloadguru-79341e9f046f373509b9ab9d14ef711797d5bfa5.tar.gz
guru-79341e9f046f373509b9ab9d14ef711797d5bfa5.tar.bz2
guru-79341e9f046f373509b9ab9d14ef711797d5bfa5.zip
*/*: ExcessiveLineLength fix most of them
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'sci-mathematics/frama-c-constant-folding')
-rw-r--r--sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-23.1.ebuild14
-rw-r--r--sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-24.0.ebuild12
-rw-r--r--sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-25.0.ebuild12
3 files changed, 23 insertions, 15 deletions
diff --git a/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-23.1.ebuild b/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-23.1.ebuild
index fac225c18..537939af7 100644
--- a/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-23.1.ebuild
+++ b/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-23.1.ebuild
@@ -22,6 +22,8 @@ RDEPEND="~sci-mathematics/frama-c-${PV}:=[ocamlopt?]
~sci-mathematics/frama-c-eva-${PV}:=[ocamlopt?]"
DEPEND="${RDEPEND}"
+p="src/plugins/constant_propagation/Makefile"
+
src_prepare() {
mv configure.in configure.ac || die
sed -i 's/configure\.in/configure.ac/g' Makefile.generating Makefile || die
@@ -39,9 +41,11 @@ src_configure() {
--enable-eva \
--enable-callgraph \
--enable-server
- printf 'include share/Makefile.config\n' > src/plugins/constant_propagation/Makefile || die
- sed -e '/^# *Constant propagation/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> src/plugins/constant_propagation/Makefile || die
- printf 'include share/Makefile.dynamic\n' >> src/plugins/constant_propagation/Makefile || die
+
+
+ printf 'include share/Makefile.config\n' > ${p} || die
+ sed -e '/^# *Constant propagation/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> ${p} || die
+ printf 'include share/Makefile.dynamic\n' >> ${p} || die
export FRAMAC_SHARE="${ESYSROOT}/usr/share/frama-c"
export FRAMAC_LIBDIR="${EPREFIX}/usr/$(get_libdir)/frama-c"
export ENABLE_EVA=yes
@@ -51,9 +55,9 @@ src_configure() {
src_compile() {
tc-export AR
- emake -f src/plugins/constant_propagation/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
+ emake -f ${p} FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
}
src_install() {
- emake -f src/plugins/constant_propagation/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
+ emake -f ${p} FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
}
diff --git a/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-24.0.ebuild b/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-24.0.ebuild
index 5f3078343..346b52c56 100644
--- a/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-24.0.ebuild
+++ b/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-24.0.ebuild
@@ -22,6 +22,8 @@ RDEPEND="~sci-mathematics/frama-c-${PV}:=[ocamlopt?]
~sci-mathematics/frama-c-eva-${PV}:=[ocamlopt?]"
DEPEND="${RDEPEND}"
+p="src/plugins/constant_propagation/Makefile"
+
src_prepare() {
mv configure.in configure.ac || die
sed -i 's/configure\.in/configure.ac/g' Makefile.generating Makefile || die
@@ -39,9 +41,9 @@ src_configure() {
--enable-eva \
--enable-callgraph \
--enable-server
- printf 'include share/Makefile.config\n' > src/plugins/constant_propagation/Makefile || die
- sed -e '/^# *Constant propagation/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> src/plugins/constant_propagation/Makefile || die
- printf 'include share/Makefile.dynamic\n' >> src/plugins/constant_propagation/Makefile || die
+ printf 'include share/Makefile.config\n' > ${p} || die
+ sed -e '/^# *Constant propagation/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> ${p} || die
+ printf 'include share/Makefile.dynamic\n' >> ${p} || die
export FRAMAC_SHARE="${ESYSROOT}/usr/share/frama-c"
export FRAMAC_LIBDIR="${EPREFIX}/usr/$(get_libdir)/frama-c"
export ENABLE_EVA=yes
@@ -51,9 +53,9 @@ src_configure() {
src_compile() {
tc-export AR
- emake -f src/plugins/constant_propagation/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
+ emake -f ${p} FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
}
src_install() {
- emake -f src/plugins/constant_propagation/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
+ emake -f ${p} FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
}
diff --git a/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-25.0.ebuild b/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-25.0.ebuild
index 47760202b..ef5204deb 100644
--- a/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-25.0.ebuild
+++ b/sci-mathematics/frama-c-constant-folding/frama-c-constant-folding-25.0.ebuild
@@ -22,6 +22,8 @@ RDEPEND="~sci-mathematics/frama-c-${PV}:=[ocamlopt?]
~sci-mathematics/frama-c-eva-${PV}:=[ocamlopt?]"
DEPEND="${RDEPEND}"
+p="src/plugins/constant_propagation/Makefile"
+
src_prepare() {
mv configure.in configure.ac || die
sed -i 's/configure\.in/configure.ac/g' Makefile.generating Makefile || die
@@ -38,9 +40,9 @@ src_configure() {
--enable-semantic-constant-folding \
--enable-eva \
--enable-server
- printf 'include share/Makefile.config\n' > src/plugins/constant_propagation/Makefile || die
- sed -e '/^# *Constant propagation/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> src/plugins/constant_propagation/Makefile || die
- printf 'include share/Makefile.dynamic\n' >> src/plugins/constant_propagation/Makefile || die
+ printf 'include share/Makefile.config\n' > ${p} || die
+ sed -e '/^# *Constant propagation/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> ${p} || die
+ printf 'include share/Makefile.dynamic\n' >> ${p} || die
export FRAMAC_SHARE="${ESYSROOT}/usr/share/frama-c"
export FRAMAC_LIBDIR="${EPREFIX}/usr/$(get_libdir)/frama-c"
export ENABLE_EVA=yes
@@ -48,9 +50,9 @@ src_configure() {
}
src_compile() {
- emake -f src/plugins/constant_propagation/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
+ emake -f ${p} FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
}
src_install() {
- emake -f src/plugins/constant_propagation/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
+ emake -f ${p} FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
}