aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-14 17:54:04 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-15 22:34:21 +0200
commitfbd84d74842d9ab103ba5761d157a3d6cda31777 (patch)
treea1ca57f0e2ee3140f4b954ddd82ce8ade3ff78bc /sci-mathematics
parentdev-python/rchitect: initial import (diff)
downloadguru-fbd84d74842d9ab103ba5761d157a3d6cda31777.tar.gz
guru-fbd84d74842d9ab103ba5761d157a3d6cda31777.tar.bz2
guru-fbd84d74842d9ab103ba5761d157a3d6cda31777.zip
sci-mathematics/radian: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/radian/Manifest1
-rw-r--r--sci-mathematics/radian/files/radian-0.6.0-no-pytest-runner.patch9
-rw-r--r--sci-mathematics/radian/metadata.xml35
-rw-r--r--sci-mathematics/radian/radian-0.6.0.ebuild44
4 files changed, 89 insertions, 0 deletions
diff --git a/sci-mathematics/radian/Manifest b/sci-mathematics/radian/Manifest
new file mode 100644
index 000000000..9b2202d0a
--- /dev/null
+++ b/sci-mathematics/radian/Manifest
@@ -0,0 +1 @@
+DIST radian-0.6.0.tar.gz 53164 BLAKE2B e2384beb41b1099830afb4f48ad4d220da2fc0267df2968ec51164dd1b592705c63c185767a2a229528ac0156391b41299c747c3ea552da31dea6a0eda6e65f8 SHA512 e7b1b22347c9d6cf7b80b1c07cdbb30942b4c285fea211a0ee53b1874f7dac33d0c139fc04a8efb19a19161dbac6642a98c6a134b36371b1c2f6514c79be5407
diff --git a/sci-mathematics/radian/files/radian-0.6.0-no-pytest-runner.patch b/sci-mathematics/radian/files/radian-0.6.0-no-pytest-runner.patch
new file mode 100644
index 000000000..a1ce1ddc7
--- /dev/null
+++ b/sci-mathematics/radian/files/radian-0.6.0-no-pytest-runner.patch
@@ -0,0 +1,9 @@
+--- a/setup.py
++++ b/setup.py
+@@ -55,6 +55,5 @@
+ extras_require={
+ "test": tests_deps
+ },
+- setup_requires=["pytest-runner"],
+ tests_require=tests_deps
+ )
diff --git a/sci-mathematics/radian/metadata.xml b/sci-mathematics/radian/metadata.xml
new file mode 100644
index 000000000..8411a8632
--- /dev/null
+++ b/sci-mathematics/radian/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+radian is an alternative console for the R program with multiline editing and rich syntax highlight. One would consider radian as a ipython clone for R, though its design is more aligned to julia.
+
+Features
+ cross platform, runs on Windows, macOS and Linux
+ shell mode: hit ; to enter and &lt;backspace&gt; to leave
+ reticulate python repl mode: hit ~ to enter
+ improved R prompt and reticulate python prompt
+ multiline editing
+ syntax highlight
+ auto completion (reticulate autocompletion depends on jedi)
+ unicode support
+ latex completion
+ auto matching parens/quotes.
+ bracketed paste mode
+ emacs/vi editing mode
+ automatically adjust to terminal width
+ read more than 4096 bytes per line
+ </longdescription>
+ <upstream>
+ <remote-id type="github">randy3k/radian</remote-id>
+ <remote-id type="pypi">radian</remote-id>
+ <maintainer status="unknown">
+ <email>randy.cs.lai@gmail.com</email>
+ <name>Randy Lai</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/radian/radian-0.6.0.ebuild b/sci-mathematics/radian/radian-0.6.0.ebuild
new file mode 100644
index 000000000..f82d06ee1
--- /dev/null
+++ b/sci-mathematics/radian/radian-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A 21 century R console"
+HOMEPAGE="
+ https://pypi.org/project/radian/
+ https://github.com/randy3k/radian
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/rchitect-0.3.36[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-3.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.5.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/R
+"
+BDEPEND="
+ test? (
+ >=dev-python/pyte-0.8.0[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-pytest-runner.patch" )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "prompt completions" dev-python/jedi
+}