aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtemis Everfree <artemis@artemis.sh>2023-10-31 22:19:18 -0700
committerArtemis Everfree <artemis@artemis.sh>2023-10-31 22:20:44 -0700
commit1244f6319252d6b52cca41a7c82e9e77208fe2e3 (patch)
tree9e903279f79b1cb28c613e52a67de3485031ae7a /sys-boot
parentsys-kernel/ugrd: add github upstream metadata (diff)
downloadguru-1244f6319252d6b52cca41a7c82e9e77208fe2e3.tar.gz
guru-1244f6319252d6b52cca41a7c82e9e77208fe2e3.tar.bz2
guru-1244f6319252d6b52cca41a7c82e9e77208fe2e3.zip
sys-boot/zfsbootmenu: add 2.2.1
Signed-off-by: Artemis Everfree <artemis@artemis.sh>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/zfsbootmenu/Manifest1
-rw-r--r--sys-boot/zfsbootmenu/zfsbootmenu-2.2.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-boot/zfsbootmenu/Manifest b/sys-boot/zfsbootmenu/Manifest
index c25b59cb0..f5cb57dd6 100644
--- a/sys-boot/zfsbootmenu/Manifest
+++ b/sys-boot/zfsbootmenu/Manifest
@@ -1,2 +1,3 @@
DIST zfsbootmenu-1.12.0.tar.gz 1688946 BLAKE2B 291dcc813767def653bc4983cb9ff4c5b1d9f191cb8fee6e9a58cd6826fe0204606aa095339e9eeb6e4dd3201f5f9ad1b4cc3a26712960bf057198225f4b65f9 SHA512 5af3d258eee3ade3e9e11e084f4de0d251acc952348fdc4d3656b32f8fec7460c2d59fa883e06f482bd2f59e1055d6b908cf43c29aee47059d369231197a6645
DIST zfsbootmenu-2.2.0.tar.gz 1825473 BLAKE2B 3ec2c3b7fb7bfa0f2859978bbfe61fea0702000e8eeb03040cab6230195bb413d8e29dc256154606a3330ab403d05908fe2df6190c133885877e45948e7d5429 SHA512 7428ce3d5b168e65d26e9f2e26196d48287f16ed05c650600990fc5effa27c68d9f3af03eeb16ae7158c761e489ecef31bfbd868c64cc0bdee356ed00e7c0cfe
+DIST zfsbootmenu-2.2.1.tar.gz 1829045 BLAKE2B 29f7dad1d94e8c6ab1466be81fa9dd8f01571d0e59791343eabb8f20f18c42aa71c0903539c578c8dbb0b91a563a310742e35a1844cafe71306010a928dd2e7c SHA512 8d30df97c8a3371727f2403eca35b63bd3817c27e6d9734fb790c193a023af66d988a074c9ddb5c3db2610b9d1b8666e4d5b304d17c64bf9df1f199a1349d45a
diff --git a/sys-boot/zfsbootmenu/zfsbootmenu-2.2.1.ebuild b/sys-boot/zfsbootmenu/zfsbootmenu-2.2.1.ebuild
new file mode 100644
index 000000000..3cc05da39
--- /dev/null
+++ b/sys-boot/zfsbootmenu/zfsbootmenu-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="ZFS bootloader for root-on-ZFS systems"
+HOMEPAGE="https://zfsbootmenu.org"
+SRC_URI="https://github.com/zbm-dev/zfsbootmenu/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-stub-location.patch
+)
+
+RDEPEND="
+app-shells/fzf
+dev-lang/perl
+dev-perl/boolean
+dev-perl/Config-IniFiles
+dev-perl/Sort-Versions
+dev-perl/YAML-PP
+sys-apps/kexec-tools
+sys-block/mbuffer
+sys-fs/zfs
+sys-kernel/dracut
+"
+
+src_compile() {
+ # There's a makefile in the source repo but it's only for install. There's
+ # nothing to compile since zfsbootmenu is all scripts.
+ true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst () {
+ elog "Please consult upstream doumentation to install the bootloader
+ https://github.com/zbm-dev/zfsbootmenu"
+}