aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-03-25 11:01:03 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-03-25 11:01:03 +0100
commit56ddc690ec17e4af12ff5519c41083ba1bd11fa8 (patch)
tree42888ee514fe01b86fbaa826cdbdd36eb63f4d4f /sys-boot
parentapp-misc/fastfetch: add 1.11.0 (diff)
downloadguru-56ddc690ec17e4af12ff5519c41083ba1bd11fa8.tar.gz
guru-56ddc690ec17e4af12ff5519c41083ba1bd11fa8.tar.bz2
guru-56ddc690ec17e4af12ff5519c41083ba1bd11fa8.zip
sys-boot/limine: add 4.20230325.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-4.20230325.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 378c324a0..02ad355a5 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -13,3 +13,4 @@ DIST limine-4.20230307.0.tar.xz 783112 BLAKE2B 108340d15aca9954c22bf78e2abcc1d1f
DIST limine-4.20230308.0.tar.xz 783384 BLAKE2B 2aa80c90b495f3fa09b5324fa58a8fa547f6763924bef7b0b82e1c02b56e0ea9a1c9cc3afab698450c37d9ec4146dd4b621ea93208733c285793a10fa153fba2 SHA512 e715dc27936037248fc8be7e1cd4f460af40217eff74e90cd56562d252c915ee97c8b8129bb523043a3e57cfbca8846fc2a0183d8c6337e9bca2e763ed306ec3
DIST limine-4.20230315.0.tar.xz 897716 BLAKE2B ca46816a2fd326fa3ac642b3b3ca3cc6fdef3d68831cebe7b52dcb2a3fe818a5aa249ff2d69e44e31f64cdcce5a7f32914e6264fc175687e2b62115a5e7238ff SHA512 58dbea3f55913ffae938367ff0f5e1a13fe7439bac6e7766a00909dbab01eeb05da2120bbcda46f1b3fa3ff170f8adbf2d2f5e589cb6c3581327c2ee175445de
DIST limine-4.20230317.0.tar.xz 897632 BLAKE2B bdf1911905057a751edce95566d39ba9c8a058e6b3f7a2453978a27c0720b91c6658b1906192e3c091ea1b59853201de02a9136304fc077430fddaf763484068 SHA512 e9b0316004baa45a6a9a205e1904d91d68e4ce6379edfd8ca1c722f5da4d06a80c77af3d1fd0778970a6765389aa26793e00796862bf5f16b1defd1a8918f323
+DIST limine-4.20230325.0.tar.xz 897164 BLAKE2B ce0ca350667210e0bf1fedfebee97e1763ca706b7f756e4d81fcd0ba35df436efac987bc9cb784dfc99ac770fcc5feee6145d763dc8df67f61231013262511ec SHA512 bfe6dbd9b8bc636431a6e494ce636bd29a2c6df1cd568621e980fe17f026a2bca14a1ca6d4c8d45a30f37f6ac99e62e94eccdbcebea52bc73783fbcf049a9369
diff --git a/sys-boot/limine/limine-4.20230325.0.ebuild b/sys-boot/limine/limine-4.20230325.0.ebuild
new file mode 100644
index 000000000..a93073081
--- /dev/null
+++ b/sys-boot/limine/limine-4.20230325.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}