aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtemis Everfree <artemis@artemis.sh>2024-02-03 23:26:37 -0800
committerArtemis Everfree <artemis@artemis.sh>2024-02-03 23:28:36 -0800
commit579927a80f98f914da0c66f049a28c828610ecba (patch)
tree540e2c20843d45d19056136fa2cca5def32580fa /sys-boot
parentmedia-fonts/plemoljp: add 1.7.0, drop 1.6.0 (diff)
downloadguru-579927a80f98f914da0c66f049a28c828610ecba.tar.gz
guru-579927a80f98f914da0c66f049a28c828610ecba.tar.bz2
guru-579927a80f98f914da0c66f049a28c828610ecba.zip
sys-boot/zfsbootmenu: add 2.3.0
Signed-off-by: Artemis Everfree <artemis@artemis.sh>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/zfsbootmenu/Manifest1
-rw-r--r--sys-boot/zfsbootmenu/zfsbootmenu-2.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-boot/zfsbootmenu/Manifest b/sys-boot/zfsbootmenu/Manifest
index f78b88b0e..f02621a2a 100644
--- a/sys-boot/zfsbootmenu/Manifest
+++ b/sys-boot/zfsbootmenu/Manifest
@@ -2,3 +2,4 @@ DIST zfsbootmenu-1.12.0.tar.gz 1688946 BLAKE2B 291dcc813767def653bc4983cb9ff4c5b
DIST zfsbootmenu-2.2.0.tar.gz 1825473 BLAKE2B 3ec2c3b7fb7bfa0f2859978bbfe61fea0702000e8eeb03040cab6230195bb413d8e29dc256154606a3330ab403d05908fe2df6190c133885877e45948e7d5429 SHA512 7428ce3d5b168e65d26e9f2e26196d48287f16ed05c650600990fc5effa27c68d9f3af03eeb16ae7158c761e489ecef31bfbd868c64cc0bdee356ed00e7c0cfe
DIST zfsbootmenu-2.2.1.tar.gz 1829045 BLAKE2B 29f7dad1d94e8c6ab1466be81fa9dd8f01571d0e59791343eabb8f20f18c42aa71c0903539c578c8dbb0b91a563a310742e35a1844cafe71306010a928dd2e7c SHA512 8d30df97c8a3371727f2403eca35b63bd3817c27e6d9734fb790c193a023af66d988a074c9ddb5c3db2610b9d1b8666e4d5b304d17c64bf9df1f199a1349d45a
DIST zfsbootmenu-2.2.2.tar.gz 1830178 BLAKE2B e2191e26215214ce2ed803bf0659aea9ba629fcb35acb75e6398731b5edcee4bc2820203844c80998e39fd4c6eb904244fce6a37126038cd816156466976100a SHA512 895491305bf97147252a63a28d378823068e83417146a949d018b49b6e6d3274af434e8047082dad08494f6db44429a9948531321750b88b0eaf282710356914
+DIST zfsbootmenu-2.3.0.tar.gz 1891010 BLAKE2B 2e84204994008c85ba0ad7231fe442bd02cbb45d57b3dfd707b86d1484b155dc8309958cd66d90336897e9841596aa74d6ffa4a969bca0e65679806ac8233e94 SHA512 9b8e2d5ea258a32cd09a9382faaa21beea54f2ed825fa747f10ffe0b9f191c257b023019ec76dc882e649e8ea6fcd8e310632bba6c783228c594e3d0fee2c9c8
diff --git a/sys-boot/zfsbootmenu/zfsbootmenu-2.3.0.ebuild b/sys-boot/zfsbootmenu/zfsbootmenu-2.3.0.ebuild
new file mode 100644
index 000000000..655734a81
--- /dev/null
+++ b/sys-boot/zfsbootmenu/zfsbootmenu-2.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="ZFS bootloader for root-on-ZFS systems"
+HOMEPAGE="https://zfsbootmenu.org"
+SRC_URI="https://github.com/zbm-dev/zfsbootmenu/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-stub-location.patch
+)
+
+RDEPEND="
+app-shells/fzf
+dev-lang/perl
+dev-perl/boolean
+dev-perl/Config-IniFiles
+dev-perl/Sort-Versions
+dev-perl/YAML-PP
+sys-apps/kexec-tools
+sys-block/mbuffer
+sys-fs/zfs
+sys-kernel/dracut
+"
+
+src_compile() {
+ # There's a makefile in the source repo but it's only for install. There's
+ # nothing to compile since zfsbootmenu is all scripts.
+ true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst () {
+ elog "Please consult upstream doumentation to install the bootloader
+ https://github.com/zbm-dev/zfsbootmenu"
+}