aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-06-19 00:33:41 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-06-19 00:34:20 +0200
commit9ab5a6d653ac1f49dc5ca1239eddeaee5da25904 (patch)
tree2f751b1d191dd4eb805f7f0847faa21141df7f75 /sys-boot
parentgames-util/xivlauncher: add 1.0.4, drop 1.0.3-r1 (diff)
downloadguru-9ab5a6d653ac1f49dc5ca1239eddeaee5da25904.tar.gz
guru-9ab5a6d653ac1f49dc5ca1239eddeaee5da25904.tar.bz2
guru-9ab5a6d653ac1f49dc5ca1239eddeaee5da25904.zip
sys-boot/limine: add 4.20230615.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-4.20230615.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index b43e0ea1a..ff09f7ba1 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -8,3 +8,4 @@ DIST limine-4.20230514.0.tar.xz 966160 BLAKE2B 6556adc6c2efffb2876c103b4428f42b5
DIST limine-4.20230529.0.tar.xz 961384 BLAKE2B 3345fb306f4c215719e0839200633e7ed46e4aa845918464d79c6a65c5a0d325305e1372ebcac58c9e28e37193c49dc3cc084f1ed584cda1c0004ee6564bf835 SHA512 bf679b8f833fbe3b6c3926da0b4cda066f7050d87cf29c59b1ca2998d05b15b7d5539f289e9871eb6e185caadd5ace9d994839ff4fbcaadfc28c7e16d61c7261
DIST limine-4.20230530.0.tar.xz 960956 BLAKE2B bf68ac2f360874b56d91fa009efb59faeedd5a834c8be9ed0ccf7e717e6d9e751c2aca7a6e2e0837ee17431e41235e79aeb8a95230791a35c3c82cca9cfeb5b8 SHA512 ab5823c8b34265d3e8d87bfd0bec1623fc0151bae1df9f28dab29acd506105a3d9d171949656fa9a5ae1d1c63ac2a02542552b3c95f072a94adff45081c98fd4
DIST limine-4.20230606.0.tar.xz 963232 BLAKE2B 613a0d5c5893f2cff1398c03a08c50c60b448f73a4b1f568dde0f2de1bea59ac8ecfaa398e5b601c3eea5c0fcea778a88a178fdaa77acd2236de9f56a7da8cc4 SHA512 617d9ad2d0e34222e88fbbec92593d5e7cc5634487b469effefafd94d5c5c3189c5fa5261a83850d79ae7d60f63a460ee4ff0e499a0c833839f3e07af07aec42
+DIST limine-4.20230615.0.tar.xz 963720 BLAKE2B a4124be763c84ded9367cffc965ca60c6e4360e870f19342e8feb3d018ed33b26753c105c3dbe1db6580b5760c57ec08858fddb9bb29e9de466c0bbe31752ade SHA512 2d06ff827a6720d6974bdbff88010c08772c4110a2c106bec089333a6b1ea50176a8e43930550af483d0c6fab3606744b6b36fcd930dc660934925ed06faa76a
diff --git a/sys-boot/limine/limine-4.20230615.0.ebuild b/sys-boot/limine/limine-4.20230615.0.ebuild
new file mode 100644
index 000000000..5a72ed2ff
--- /dev/null
+++ b/sys-boot/limine/limine-4.20230615.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}