aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2024-01-20 18:00:33 +0100
committerArsen Arsenović <arsen@gentoo.org>2024-01-20 18:00:33 +0100
commitad13953936d8b0edd9573b10b3f36a6a3b86dff5 (patch)
tree2893de10385cf50edc7492857d9c09161f4de7b5 /sys-boot
parentnet-im/heisenbridge: enable py3.12 (diff)
downloadguru-ad13953936d8b0edd9573b10b3f36a6a3b86dff5.tar.gz
guru-ad13953936d8b0edd9573b10b3f36a6a3b86dff5.tar.bz2
guru-ad13953936d8b0edd9573b10b3f36a6a3b86dff5.zip
sys-boot/limine: add 7.0.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-7.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 0aca56a54..409f92b9e 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -9,3 +9,4 @@ DIST limine-5.20231103.0.tar.xz 1349960 BLAKE2B 72348e39ad8cd614e19d88c840580c58
DIST limine-5.20231121.0.tar.xz 1366372 BLAKE2B b47b4da7be451d60c6da2c0c0d2df57fce9e767e6ae1b9a59e3e823bfcc492292363560bac70960399d23f5ff6f02ce94985f7f955e18d71c0c48f0e8faa3be7 SHA512 5ab7d0b578af39af0ffb980ecae282431bcaf463a60211d35ed229ef3e1c5f8d9392bbbee64732e70dd87411bedf233e32e953f714cecc44edad4b254221e761
DIST limine-5.20231124.0.tar.xz 1322812 BLAKE2B 8f15e8a77107a0b49cc58372d59b0fdfedaaaea0c82e46c8e86324e6fee1587f0d878ba77d70f3f24a19cc1a08cd5fc604d21f2252a53fc89f33a0a613874b62 SHA512 af37524f0d59de83f36921939c78421ce864343ef621a4b9ff1437c89080f9ef6467a04ea31f44f3904820dface10703f43b185d11a679bb7536d4573d2295c5
DIST limine-6.20231227.0.tar.xz 1318188 BLAKE2B ff7c35fbe9b1ace85450b1e568b2acb8e8165d6465300e6401c2255390dfce981b1cba2cb3065614d422904c20b75c42bf6702884bdda0a9b0b7056df19ae1f8 SHA512 b716631c371774e3d48eee1aa6ff16234f9f9572a191b9cb39a9c18c8f60f08ab07a1e351f2e5efbc616a739a32f6e24cfaaf4ca9b04688018d2728a156f9677
+DIST limine-7.0.0.tar.xz 1318064 BLAKE2B 7986d948fe84c80b338e5cc66edca5f511d277d2e854484c87183666bf1b075480b61213c177b6e39a1145502cc9e07b9e1442c3dcf3171339af5b55ac9c184f SHA512 40575711e0e51799cbca2b2de74eff813022ab760c32de7d485f0cb70aa6daa8c842d20ed3d740e8c59e4be63eab43969b0cf809f2e796107d7e9be221bd9bf6
diff --git a/sys-boot/limine/limine-7.0.0.ebuild b/sys-boot/limine/limine-7.0.0.ebuild
new file mode 100644
index 000000000..73ea27214
--- /dev/null
+++ b/sys-boot/limine/limine-7.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}