aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-02-04 06:27:13 -0500
committerJoe Kappus <joe@wt.gd>2023-02-04 06:27:13 -0500
commitf766b3d9eb3018d6aca531c5a64ba97bd35fc947 (patch)
treeec880be0695b270ca35a4f6b01518459aa1d6288 /sys-devel
parentsys-power/linux-tools-power-x86: add 6.1, drop py3.8 (diff)
downloadguru-f766b3d9eb3018d6aca531c5a64ba97bd35fc947.tar.gz
guru-f766b3d9eb3018d6aca531c5a64ba97bd35fc947.tar.bz2
guru-f766b3d9eb3018d6aca531c5a64ba97bd35fc947.zip
sys-devel/just: run tc-export CC
Should make QA happy Closes: https://bugs.gentoo.org/892563 Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/just/just-1.12.0.ebuild12
-rw-r--r--sys-devel/just/just-1.13.0.ebuild12
2 files changed, 16 insertions, 8 deletions
diff --git a/sys-devel/just/just-1.12.0.ebuild b/sys-devel/just/just-1.12.0.ebuild
index f3bf66624..89cf59ab7 100644
--- a/sys-devel/just/just-1.12.0.ebuild
+++ b/sys-devel/just/just-1.12.0.ebuild
@@ -116,7 +116,7 @@ CRATES="
${P}
"
-inherit bash-completion-r1 cargo
+inherit bash-completion-r1 cargo toolchain-funcs
DESCRIPTION="Just a command runner (with syntax inspired by 'make')"
HOMEPAGE="
@@ -134,10 +134,14 @@ RESTRICT="mirror"
QA_FLAGS_IGNORED="usr/bin/just"
src_test() {
- # $USER must be set or tests fail Bug #890889
- export USER=portage
+ # $USER must be set or tests fail Bug #890889
+ export USER=portage
+ default
+}
- default
+src_prepare() {
+ default
+ tc-export CC
}
src_install() {
diff --git a/sys-devel/just/just-1.13.0.ebuild b/sys-devel/just/just-1.13.0.ebuild
index 89e32e906..ebcc0d139 100644
--- a/sys-devel/just/just-1.13.0.ebuild
+++ b/sys-devel/just/just-1.13.0.ebuild
@@ -116,7 +116,7 @@ CRATES="
${P}
"
-inherit bash-completion-r1 cargo
+inherit bash-completion-r1 cargo toolchain-funcs
DESCRIPTION="Just a command runner (with syntax inspired by 'make')"
HOMEPAGE="
@@ -134,10 +134,14 @@ RESTRICT="mirror"
QA_FLAGS_IGNORED="usr/bin/just"
src_test() {
- # $USER must be set or tests fail Bug #890889
- export USER=portage
+ # $USER must be set or tests fail Bug #890889
+ export USER=portage
+ default
+}
- default
+src_prepare() {
+ default
+ tc-export CC
}
src_install() {