aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-08 13:49:09 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-08 13:52:10 +0100
commitcf323d4285393bc101f08024a5a21f8d1684701d (patch)
treeb92fe42411e2f4e94bad41b262b154236d408e62 /sys-firmware
parentdev-python/undervolt: new package, add 0.3.0, 9999 (diff)
downloadguru-cf323d4285393bc101f08024a5a21f8d1684701d.tar.gz
guru-cf323d4285393bc101f08024a5a21f8d1684701d.tar.bz2
guru-cf323d4285393bc101f08024a5a21f8d1684701d.zip
sys-firmware/LenovoLegionLinux: add undervolt dependency
* Intel user * fix identation to tabs Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/LenovoLegionLinux/LenovoLegionLinux-9999.ebuild25
-rw-r--r--sys-firmware/LenovoLegionLinux/metadata.xml3
2 files changed, 14 insertions, 14 deletions
diff --git a/sys-firmware/LenovoLegionLinux/LenovoLegionLinux-9999.ebuild b/sys-firmware/LenovoLegionLinux/LenovoLegionLinux-9999.ebuild
index 435ed60113..28c41777ae 100644
--- a/sys-firmware/LenovoLegionLinux/LenovoLegionLinux-9999.ebuild
+++ b/sys-firmware/LenovoLegionLinux/LenovoLegionLinux-9999.ebuild
@@ -21,14 +21,15 @@ RDEPEND="sys-kernel/linux-headers
radeon-dgpu? ( dev-util/rocm-smi )
downgrade-nvidia? ( <=x11-drivers/nvidia-drivers-525 )
ryzenadj? ( sys-power/RyzenAdj )
+ undervolt-intel? ( dev-python/undervolt )
"
DEPEND="${RDEPEND}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="legion-tools legion-acpi systemd radeon-dgpu downgrade-nvidia ryzenadj"
-REQUIRED_USE="|| ( systemd legion-acpi radeon-dgpu downgrade-nvidia ryzenadj legion-tools ) legion-acpi? ( legion-tools ) radeon-dgpu? ( !downgrade-nvidia legion-tools ) downgrade-nvidia? ( !radeon-dgpu legion-tools )"
+IUSE="legion-tools legion-acpi systemd radeon-dgpu downgrade-nvidia ryzenadj undervolt-intel"
+REQUIRED_USE="|| ( systemd legion-acpi radeon-dgpu downgrade-nvidia ryzenadj legion-tools undervolt-intel ) legion-acpi? ( legion-tools ) radeon-dgpu? ( !downgrade-nvidia legion-tools ) downgrade-nvidia? ( !radeon-dgpu legion-tools ) undervolt-intel? ( !ryzenadj legion-tools ) ryzenadj? ( !undervolt-intel legion-tools )"
MODULES_KERNEL_MIN=5.10
@@ -36,7 +37,7 @@ src_compile() {
local modlist=(
legion-laptop=kernel/drivers/platform/x86:kernel_module:kernel_module:all
)
- KERNELVERSION=${KV_FULL} linux-mod-r1_src_compile
+ KERNELVERSION=${KV_FULL} linux-mod-r1_src_compile
if use legion-tools; then
#Define build dir (fix sandboxed)
cd "${WORKDIR}/${P}/python/legion_linux"
@@ -60,7 +61,7 @@ src_install() {
if use legion-acpi; then
insinto /etc/acpi/events/ && doins acpi/events/{ac_adapter_legion-fancurve,novo-button,PrtSc-button,fn-r-refrate}
insinto /etc/acpi/actions/ && doins acpi/actions/{battery-legion-quiet.sh,snipping-tool.sh,fn-r-refresh-rate.sh}
- fi
+ fi
if use systemd; then
systemd_dounit service/legion-linux.service service/legion-linux.path
@@ -69,20 +70,20 @@ src_install() {
insinto /etc/legion_linux && doins service/profiles/*
#AMD
- if use radeon-dgpu; then
+ if use radeon-dgpu; then
insinto /usr/share/legion_linux && newins "${FILESDIR}/radeon" .env
insinto /etc/legion_linux && newins "${FILESDIR}/radeon" .env
- fi
- #NVIDIA (need dowgrade because nvidia-smi -pl was removed)
+ fi
+ #NVIDIA (need dowgrade because nvidia-smi -pl was removed)
if use downgrade-nvidia; then
insinto /usr/share/legion_linux && newins "${FILESDIR}/nvidia" .env
insinto /etc/legion_linux && newins "${FILESDIR}/nvidia" .env
- fi
+ fi
if use ryzenadj; then
insinto /usr/share/legion_linux && newins "${FILESDIR}/cpu" .env
insinto /etc/legion_linux && newins "${FILESDIR}/cpu" .env
- fi
+ fi
fi
# Desktop Files and Polkit
@@ -99,9 +100,7 @@ pkg_postinst() {
ewarn "Pls copy that folder to /etc/legion_linux and edit the fancurves to your liking"
ewarn "Note:can be done using the gui app"
ewarn "Dont forget to edit /etc/legion_linux/.env to enable and disable extra features"
- ewarn "Note: use flag downgrade-nvidia in need for nvidia TDP control"
+ ewarn "Note the CPU and APU control command both for undervolt an ryzenadj are edit in /etc/legion_linux/.env command"
+ ewarn "Note: use flag downgrade-nvidia in need for nvidia TDP control\n"
fi
- ewarn "For Intel Users is need to install undervolt manally since and ebuild exist"
- ewarn "Undervolt Repo: https://github.com/georgewhewell/undervolt"
- ewarn "More information on this README: https://github.com/Petingoso/legion-fan-utils-linux/blob/main/README.md"
}
diff --git a/sys-firmware/LenovoLegionLinux/metadata.xml b/sys-firmware/LenovoLegionLinux/metadata.xml
index 479623d1d2..660ba14f53 100644
--- a/sys-firmware/LenovoLegionLinux/metadata.xml
+++ b/sys-firmware/LenovoLegionLinux/metadata.xml
@@ -6,7 +6,8 @@
<flag name="legion-acpi">Install acpi script (experimental feature)</flag>
<flag name="radeon-dgpu">Enable AMD GPU TDP control (systemd-service)</flag>
<flag name="downgrade-nvidia">Downgrade nvidia for 525 to enable TDP control (systemd-service)</flag>
- <flag name="ryzenadj">CPU and APU control using ryzenadj (systemd-service)</flag>
+ <flag name="ryzenadj">[AMD] CPU and APU control using ryzenadj (systemd-service)</flag>
+ <flag name="undervolt-intel">[INTEL] CPU and APU control using undervolt (systemd-service)</flag>
</use>
<upstream>
<remote-id type="github">johnfanv2/LenovoLegionLinux</remote-id>