aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2023-05-16 15:03:14 +0500
committerDenis Reva <denis7774@gmail.com>2023-05-16 15:03:14 +0500
commit9aaa47b79edc3a540b108fef69289c83f008983a (patch)
tree2117dbe2a0f31dfc6eba0c48f960f93a0eb68e79 /sys-fs/dwarfs
parentsys-fs/dwarfs: removed unused patch (diff)
downloadguru-9aaa47b79edc3a540b108fef69289c83f008983a.tar.gz
guru-9aaa47b79edc3a540b108fef69289c83f008983a.tar.bz2
guru-9aaa47b79edc3a540b108fef69289c83f008983a.zip
sys-fs/dwarfs: fixed bug that appears with modern compilers
clang-16 or gcc-13 Closes: https://bugs.gentoo.org/906181 Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'sys-fs/dwarfs')
-rw-r--r--sys-fs/dwarfs/dwarfs-0.7.0_rc4.ebuild5
-rw-r--r--sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-fbthrift-cstdint.patch13
-rw-r--r--sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-stdexcept.patch14
3 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/dwarfs/dwarfs-0.7.0_rc4.ebuild b/sys-fs/dwarfs/dwarfs-0.7.0_rc4.ebuild
index 3eed1ced5..74ed8fd15 100644
--- a/sys-fs/dwarfs/dwarfs-0.7.0_rc4.ebuild
+++ b/sys-fs/dwarfs/dwarfs-0.7.0_rc4.ebuild
@@ -19,6 +19,11 @@ KEYWORDS="~amd64"
IUSE="python +jemalloc test man"
S="${WORKDIR}/dwarfs-${MY_PV}"
+PATCHES=(
+ "${FILESDIR}/dwarfs-0.7.0_rc4-stdexcept.patch"
+ "${FILESDIR}/dwarfs-0.7.0_rc4-fbthrift-cstdint.patch"
+)
+
RDEPEND="
${PYTHON_DEPS}
app-arch/libarchive
diff --git a/sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-fbthrift-cstdint.patch b/sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-fbthrift-cstdint.patch
new file mode 100644
index 000000000..c52f795ee
--- /dev/null
+++ b/sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-fbthrift-cstdint.patch
@@ -0,0 +1,13 @@
+diff --git a/fbthrift/thrift/compiler/generate/json.cc b/fbthrift/thrift/compiler/generate/json.cc
+index c4d87a3..015e81f 100644
+--- a/fbthrift/thrift/compiler/generate/json.cc
++++ b/fbthrift/thrift/compiler/generate/json.cc
+@@ -18,7 +18,7 @@
+
+ #include <ostream>
+ #include <sstream>
+-
++#include <cstdint>
+ namespace apache {
+ namespace thrift {
+ namespace compiler {
diff --git a/sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-stdexcept.patch b/sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-stdexcept.patch
new file mode 100644
index 000000000..a2a671e17
--- /dev/null
+++ b/sys-fs/dwarfs/files/dwarfs-0.7.0_rc4-stdexcept.patch
@@ -0,0 +1,14 @@
+diff --git a/folly/folly/system/AtFork.cpp b/folly/folly/system/AtFork.cpp
+index e888e52..8c9eee5 100644
+--- a/folly/folly/system/AtFork.cpp
++++ b/folly/folly/system/AtFork.cpp
+@@ -20,7 +20,8 @@
+ #include <folly/lang/Exception.h>
+ #include <folly/portability/PThread.h>
+ #include <folly/synchronization/SanitizeThread.h>
+-
++#include <system_error>
++#include <stdexcept>
+ namespace folly {
+
+ void AtForkList::prepare() noexcept {